httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Will Nordmeyer <quark...@gmail.com>
Subject [users@httpd] Problems installing 2.4.7
Date Tue, 18 Feb 2014 16:22:56 GMT
Hi,

I searched the archives and tried some solutions I saw there... but
here's my issue...

I have Apache 2.4.3 installed on CentOS6 and I'm trying to build/install 2.4.7.

I downloaded and installed APR 1.5.0 and APR-UTIL 1.5.3 to /usr/local/apache2

I downloaded httpd 2.4.7 and configured with the following command:

./configure --prefix=/usr/local/apache2 --enable-modules=most
--enable-ssl --with-apr=/usr/local/apache2

When I try doing the make, I get the following errors.  I know that is
usually an APR error, but APR's up to date...

exports.c:1985: error: redefinition of 'ap_hack_apr_allocator_create'
exports.c:977: note: previous definition of
'ap_hack_apr_allocator_create' was here
exports.c:1986: error: redefinition of 'ap_hack_apr_allocator_destroy'
exports.c:978: note: previous definition of
'ap_hack_apr_allocator_destroy' was here
exports.c:1987: error: redefinition of 'ap_hack_apr_allocator_alloc'
exports.c:979: note: previous definition of
'ap_hack_apr_allocator_alloc' was here
exports.c:1988: error: redefinition of 'ap_hack_apr_allocator_free'
exports.c:980: note: previous definition of
'ap_hack_apr_allocator_free' was here

And all the others...


Any thoughts/advice?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message