httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Covener <cove...@gmail.com>
Subject Re: [users@httpd]
Date Tue, 04 Feb 2014 21:00:22 GMT
On Tue, Feb 4, 2014 at 11:53 AM,  <John_Waller@papajohns.com> wrote:
> Hi Eric. Thanks for the response. I looked at both web sites and basically
> started all over. I downloaded the pcre packages and installed. Those, of
> course, complained about dependencies so, after many times downloading some
> extra dependencies, I finally got back to the point of compiling apache.
> After I use the ./configure command, I still get the error saying it can't
> find the pcre-config, even though it is pointed to on the command line. So,
> I'm still stuck at the same point I was last week. Any other ideas?

Have you tried omitting anything about pcre from your ./configure?

When I build similar to the wiki, my configure line is very simple:

My default env:

/usr/local/svnkit/bin:/home/covener/wasbld/mantis/bin:/home/covener/bin:/home/covener/java/jre/bin:/home/covener/java/bin:/usr/bin:/etc:/usr/sbin:/usr/ucb:/usr/bin/X11:/sbin:/usr/java14/jre/bin:/usr/java14/bin:/usr/ccs/bin:/usr/vacpp/bin:/usr/sbin:/usr/local/bin:/opt/freeware/bin:/home/covener/java/bin

What I add during build:

export OBJECT_MODE=64
export CC="xlc_r -q64"
export PATH=/opt/freeware/bin:$PATH
export CONFIG_SHELL=/usr/bin/bash

export lt_cv_path_NM="/usr/bin/nm -B -X64"
export AR="ar -X64"

My configure line from config.nice:

#! /bin/sh
#
# Created by configure

CC="xlc_r -q64"; export CC
"./configure" \
"--enable-mods-shared=all" \
"--prefix=/tmp/httpd-2.4.7/built" \
"--enable-maintainer-mode" \
"CC=xlc_r -q64" \
"$@"

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message