httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yehuda Katz <yeh...@ymkatz.net>
Subject Re: [users@httpd] ReverseProxy Exchange 2013
Date Sun, 16 Feb 2014 00:19:00 GMT
Chris, are you trying to use webmail or Outlook Anywhere (or both)?
I have heard the RPC module works but never used it myself.
As for OWA, I will try it on one of my systems and see what happens.

- Y

Sent from a gizmo with a very small keyboard and hyperactive autocorrect.
On Feb 15, 2014 7:03 PM, "Chris Arnold" <carnold@electrichendrix.com> wrote:

> I figured i would hear crickets on this issue on this list :)
>
> Anybody tried this module?
> https://github.com/bombadil/mod_proxy_msrpc
>
>
> ----- Original Message -----
> From: "Chris Arnold" <carnold@electrichendrix.com>
> To: users@httpd.apache.org
> Sent: Saturday, February 15, 2014 5:48:07 PM
> Subject: [users@httpd] ReverseProxy Exchange 2013
>
> I have asked this on the exchange forum and am getting some help but they
> always say it is an apache issue and it may be but what i need is on the MS
> side. So i am asking here in the event someone here has done this.
>
> What i am trying to do: use autodiscover during a outlook email account
> setup. I have the proper SAN's on my cert and the proper DNS records (a
> host autodiscover that points to mail.domain.tld). I have autodiscover
> reverse proxied to the exchange server like this:
>
> ProxyPass /Autodiscover https://192.168.z.x/Autodiscover/Autodiscover.xml
> ProxyPassReverse /Autodiscover
> https://192.168.z.x/Autodiscover/Autodiscover.xml
>
> And i get the correct response/login when accessing this URL
> https://autodiscover.domain.tld/Autodiscover/Autodiscover.xml
>
> What is happenning: during outlook email account setup, i get the
> utodiscover prompt (fine for now) but during the search for user@domain.tldserver settings,
it comes back with "an encrypted connection could not be
> found". So i dont know what this process is looking for, like
> mail.domain.tld/owa /exchange /rpcwithcert (i have tried all those to no
> avail). Here is my entries for this part:
>
> #This rewrites https://mail.anydomain.tld to our mail server
>         RewriteEngine On
>         RewriteCond %{HTTP_HOST} ^mail\.
>         RewriteCond %{HTTPS} on
>         RewriteRule ^/(.*) https://192.168.12.9/(here is where i tried
> owa, exchange, rpcwithcert/$1 [P]
>         #RedirectMatch ^/$ /zimbra/
>
> Maybe somebody already has done this? To you i ask, if you could share
> your setup, minus your personal stuff of course, i would appreciate it very
> much.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

Mime
View raw message