httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Venkatesh Prabu Narayanan <venkateshprab...@gmail.com>
Subject Re: [users@httpd] Running two different versions of httpd in same machine
Date Sat, 22 Feb 2014 10:02:47 GMT
Hi,

Yes I know RHEL 4WS support ended. But please note that upgrading OS is not
an option as of now. As we can't roll out OS upgrade to production
immediately. Definitely we will do it later after development changes and
regression testing.

BTW, I want to know how to change the httpd.spec file for version 2.2.X to
install with different prefix so as to avoid conflict with the existing
version.

For example, existing version has httpd binary in /usr/sbin/httpd. I want
to change the new version so that it will have binary in /usr/sbin/httpd2..
Like this I want to change the path of all conflict files. Is it enough to
change the prefix alone in httpd.spec and rebuild the new version of rpm ?

Venkatesh



On Fri, Feb 21, 2014 at 8:06 PM, lists-apache <
replies-lists-a1z2-apache@listmail.innovate.net> wrote:

>
>
> ------------ Original Message ------------
> > Date: Friday, February 21, 2014 01:11:04 PM +0530
> > From: Venkatesh Prabu Narayanan <venkateshprabu06@gmail.com>
> > To: users@httpd.apache.org
> > Subject: [users@httpd] Running two different versions of httpd in
> same machine
> >
> > Hi,
> >
> > We are running apache httpd server of version 1.3.27 in our
> > production machine RHEL WS 4.0. We are running two process of
> > httpd (same version) one for proxy listening to 80 and other
> > listening in 8000. Input requests are received by this proxy and
> > it in turn redirects it to the backend httpd. Both these httpd are
> > running in RHEL WS 4.0.
> >
> > Due to some security problems, we were asked to upgrade the httpd
> > version to 2.2.X. Because of some technical issues, we cannot
> > upgrade the backend httpd immediately. So we planned to upgrade
> > only the front end proxy httpd such that front end proxy (facing
> > customer end) runs with 2.2.X version and the back end httpd
> > continues with the previous one.
> >
> > I believe running two different versions of httpd in the same
> > machine will not cause any issues. Please correct me if I am wrong.
> >
> > As we don't find httpd rpm in any RHEL repo, I compiled it from
> > source using rpmbuild command and generated httpd rpm with 2.2.X.
> > As we have to install instead of upgrade over previous version, I
> > have to install this new version in a different directory (i.e to
> > change prefix in config options) say 'httpd2' or some thing
> > similar to avoid conflict issues with the existing version.
> > What are the changes I have to do in httpd.spec file ?.
> >
> > Do I have to consider any other scenario for my case ?
> >
> > Thanks,
> > Venkatesh
>
>
> Your RHEL version should also be causing serious security concerns.
> Support for that release ended about a year ago so you have gotten
> no security updates since then.
>
>    Red Hat Enterprise Linux 4 - 30 day End Of Life Notice
>
>    Issued on:   2012-01-31
>
>    <https://rhn.redhat.com/errata/RHSA-2012-0073.html>
>
>
>
>   - Richard
>
>
>


-- 
Thanks and Regards

N.Venkatesh Prabu

Mime
View raw message