httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Borland <jborl...@calpoly.edu>
Subject Re: [users@httpd] Virtual Host Not Working
Date Wed, 12 Feb 2014 16:54:18 GMT
My goodness, that worked!  I am blown away!  Thank you very much for 
your help with this.

Jim

On 2/12/2014 2:58 AM, Tom Evans wrote:
> On Mon, Feb 10, 2014 at 10:24 PM, Jim Borland <jborland@calpoly.edu> wrote:
>> My server, which is located in the Amazon cloud, was just moved to a new
>> location with a new IP address.  Nothing else was changed. However, the
>> Apache Virtual Host, which has worked flawlessly for several years, is
>> broken.  Apache server version is: Apache/2.2.16 (Ubuntu).
>>
>> I went to my DNS host and changed the names to point to the new IP address.
>> But now, when I go to the hostname in my browser I end up at the default
>> site instead of the one specified for the virtual host.  Here is my config
>> file (httpd-vhosts.conf).
>>
>> ================================
>>
> Simplify your config:
>
>> NameVirtualHost *:80
>>
>> <VirtualHost *:80>
>>      ServerAdmin jborland77@gmail.com
>>      ServerName ec2-75-101-136-229.compute-1.amazonaws.com
>>      DocumentRoot "/var/www"
>> </VirtualHost>
>>
>> <Directory "/home/jim">
>>     Order allow,deny
>>     Allow from all
>> </Directory>
>>
>> <VirtualHost *:80>
>>      ServerName atascaderoband.org
>>      ServerAlias www.atascaderoband.org
>>      DocumentRoot "/home/jim/atasband"
>> </VirtualHost>
>>
>> <VirtualHost *:80>
>>      ServerName www.slocountyband.org
>>      ServerAlias slocountyband.org
>>      DocumentRoot "/home/jim/band"
>> </VirtualHost>
>>
> Work now?
>
> Cheers
>
> Tom
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>


Mime
View raw message