httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yanni Goudetsidis <goud...@gmail.com>
Subject [users@httpd] AH00020: Configuration Failed, exiting
Date Fri, 03 Jan 2014 16:20:02 GMT
Hello everyone and happy new year.

I came in this morning and tried to access my locally installed wiki page
and I was greeted with the "Unable to connect" message.I then noticed that
my httpd.service is not running and I tried to start it but wit no luck. I
am using FC19. My SELINUX is disabled.


This is the output of "systemctl status httpd.service"
-----------------------------------------------------------------------------
httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
   Active: failed (Result: exit-code) since Fri 2014-01-03 14:59:04 GMT;
17min ago
  Process: 16305 ExecStop=/usr/sbin/httpd $OPTIONS -k graceful-stop
(code=exited, status=0/SUCCESS)
  Process: 16303 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND
(code=exited, status=1/FAILURE)

Jan 03 14:59:04 paok.cryt.co.uk systemd[1]: httpd.service: main process
exited, code=exited, status=1/FAILURE
Jan 03 14:59:04 paok.cryt.co.uk httpd[16305]: httpd (no pid file) not
running
Jan 03 14:59:04 paok.cryt.co.uk systemd[1]: Failed to start The Apache HTTP
Server.
Jan 03 14:59:04 paok.cryt.co.uk systemd[1]: Unit httpd.service entered
failed state.
-----------------------------------------------------------------------------

This is what my error log shows when I attempt to start httpd:
-----------------------------------------------------------------------------
[Fri Jan 03 16:17:49.157241 2014] [suexec:notice] [pid 16948] AH01232:
suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Jan 03 16:17:49.177614 2014] [auth_digest:notice] [pid 16948] AH01757:
generating secret for digest authentication ...
[Fri Jan 03 16:17:49.177660 2014] [auth_digest:error] [pid 16948] (2)No
such file or directory: AH01762: Failed to create shared memory segment on
file /run/httpd/authdigest_shm.16948
[Fri Jan 03 16:17:49.177674 2014] [auth_digest:error] [pid 16948] (2)No
such file or directory: AH01760: failed to initialize shm - all nonce-count
checking, one-time nonces, and MD5-sess algorithm disabled
[Fri Jan 03 16:17:49.177678 2014] [:emerg] [pid 16948] AH00020:
Configuration Failed, exiting
-----------------------------------------------------------------------------

I do not understand the errors shown. Could someone please help me?

Many thanks

Mime
View raw message