httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nallu Naren <nallu.na...@gmail.com>
Subject Re: [users@httpd] Windows- 'apr_sockaddr_t::sin6' uses undefined struct 'sockaddr_in6'
Date Thu, 30 Jan 2014 09:01:11 GMT
My module uses winsock2.h from  C:\Program Files (x86)\Microsoft Visual
Studio 8\VC\PlatformSDK\Include



On Thu, Jan 30, 2014 at 1:34 PM, Hendrik Schmieder <
hendrik.schmieder@jedox.com> wrote:

> Nallu Naren schrieb:
>
>> On Wed, Jan 29, 2014 at 6:29 PM, Hendrik Schmieder
>> <hendrik.schmieder@jedox.com <mailto:hendrik.schmieder@jedox.com>> wrote:
>>
>>     Nallu Naren schrieb:
>>
>>         Hi Team,
>>
>>         I've written my own module for Apache 2.2 compiled with 2.2.16
>>         (includes
>>         and libs)and it is working as expected and now I've upgrade to
>> 2.4.7
>>         by recompiling my code with 2.4.7(includes and libs) which I've
>>         downloaded from
>>         http://www.apachehaus.com/cgi-__bin/download.plx#APACHE24VC09
>>
>>         <http://www.apachehaus.com/cgi-bin/download.plx#APACHE24VC09>
>>         and now i see the error C2079: 'apr_sockaddr_t::sin6' uses
>> undefined
>>         struct 'sockaddr_in6'
>>         c:\library\apache-httpd\2.4.7\__win32-x86\include\apr_
>> network___io.h
>>
>>         243
>>
>>         I tried adding all the header files like winsock2.h, ws2tcpip.h,
>> but
>>         nothing was solved
>>         I am using MS Visual Studio 2005 for compiling my code for 32bit
>>
>>         Could you please tell me the problem is this because of the 2.4.7
>>         (includes and libs) are not compatible with VS2005(vc8) ?
>>
>>         Thanks,
>>         -Naren
>>
>>
>>     Maybe
>>     <http://stackoverflow.com/__questions/3443836/sockaddr-__
>> in6-not-declared
>>
>>     <http://stackoverflow.com/questions/3443836/sockaddr-in6-not-declared
>> >>
>>     is of help.
>>
>>     Otherwise look from where winsock2.h is included.
>>
>>        Hendrik
>>
>>  > I've tried this, but still give me the same error.
> >
> > Do I need to use Visual Studio 2008?
> >
> >
>
> Have you looked from where winsock2.h is included ?
> (there coild be several winsock2.h).
>
>
>   Hendrik
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>


-- 
-Naren

Mime
View raw message