httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Eckert <thomas.r.w.eck...@gmail.com>
Subject Re: [users@httpd] #error mod_ssl requires OpenSSL 0.9.8a or later
Date Mon, 16 Dec 2013 09:59:16 GMT
Actually, I was referring to the openssl-dev package (and whatever other
-dev package you might need to build).



On Mon, Dec 16, 2013 at 10:53 AM, Abdul Anshad <abdul@visolve.com> wrote:

>  yes, i have httpd-devel-2.2.26 package installed. FYI i'm trying to
> build httpd-2.4.7. is it necessary to install 2.4.x dev ?
>
> Regards,
> Abdul
>
> On 12/16/2013 2:48 PM, Thomas Eckert wrote:
>
> Did you make sure to have the -dev package(s) installed ?
>
>
> On Mon, Dec 16, 2013 at 10:10 AM, Abdul Anshad <abdul@visolve.com> wrote:
>
>>  I have made sure that the --with-ssl points to the 1.0.1e, FYI i also
>> have another system binary installed which is openssl-0.9.7d.
>>
>> I have included the source of apr and apr-utils under apache srclib.
>> Apache-2.4.6 builds fine but Apache-2.4.7 throws out that error.
>>
>> when i compared both version ssl_private.h file, this is what i found.
>>
>> 108,109c108,109
>> < #if (OPENSSL_VERSION_NUMBER < 0x0090700f)
>> < #error mod_ssl requires OpenSSL 0.9.7 or later
>> ---
>> > #if (OPENSSL_VERSION_NUMBER < 0x0090801f)
>>
>> > #error mod_ssl requires OpenSSL 0.9.8a or later
>>
>>  So, why is the configure taking openssl-0.9.7d even though i have
>> specified --with-ssl option to openssl-1.0.1e ? i have double checked the
>> directory path for openssl-1.0.1e and it returns OpenSSL 1.0.1e-fips 11 Feb
>> 2013.
>>
>> Regards,
>> Abdul
>>
>>  On 12/16/2013 2:18 PM, Otis Dewitt - NOAA Affiliate wrote:
>>
>>   Try:
>>
>>  First make sure openssl-devel-1.0.1e is installed.
>>
>>  --with-ssl=<path to openssl include directory>
>>
>>  Example:
>>
>> --with-ssl=/usr/include/openssl
>>
>>
>>  Thanks,
>>  Otis
>>
>>
>>
>> On Mon, Dec 16, 2013 at 1:58 AM, Abdul Anshad <abdul@visolve.com> wrote:
>>
>>> Hello All,
>>>
>>> I'm trying to compile httpd-2.4.7 from source, but i get the following
>>> error "#error mod_ssl requires OpenSSL 0.9.8a or later".
>>>
>>> But my installed openssl version is openssl-1.0.1e and i have specified
>>> it --with-ssl option.
>>>
>>> Could anyone please help me on this ?
>>>
>>> --
>>> Regards,
>>> Abdul
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>>> For additional commands, e-mail: users-help@httpd.apache.org
>>>
>>>
>>
>>
>
>

Mime
View raw message