httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Evans <tevans...@googlemail.com>
Subject Re: [users@httpd] Issues in compiling apache server on one machine and transfer to second
Date Tue, 12 Nov 2013 11:35:44 GMT
On Tue, Nov 12, 2013 at 8:44 AM, swapnil vaidya
<swapnilsvaidya@gmail.com> wrote:
> Hi All,
> I have 2 linux machine.
> I have compiled apache 2.4.6 on one of the linux machine with following
> commands:
> ./configure --prefix=/usr/apache--with-ssl=/usr/local/ssl --enable-ssl
> --enable-modules="all" --enable-mods-shared="most"
> make
> make install
>
> This has installed apache on this machine and it works fine.
> However when i copy this apache (where it got installed) folder on other
> linux machine.
> I am getting following error while starting httpd with following commad:
> command:
> httpd -k start
>
> error:
>
> /httpd: symbol lookup error: /usr/papache/lib/libapr-1.so.0: undefined
> symbol: dlopen
>
> Can you please help me to understand what is going wrong.

Programs are linked together with libraries. Different versions of
OSes will likely have different library versions. If you compile a
dynamicly linked binary on one machine, it is only guaranteed to work
on the exact same OS/version.

Cheers

Tom

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message