httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nagaraju Kurma <nagaraju.ku...@enhancesys.com>
Subject Re: [users@httpd] unable to achieve sticky session
Date Mon, 04 Nov 2013 09:46:10 GMT
Yeah i have seen that... i am not getting anything more than my
configuration which are important.

Can u tell me whats the issue.

workers.properties
--------------------------
workers.tomcat_home=E:\Tomcat-A
workers.java_home=E:\Java\jdk1.7.0_21
#worker.list=worker1,worker2
worker.list=balancer,status

worker.worker1.port=2013
worker.worker1.host=localhost
worker.worker1.type=ajp13
worker.worker1.lbfactor=1

worker.worker2.port=7080
worker.worker2.host=localhost
worker.worker2.type=ajp13
worker.worker2.lbfactor=1

worker.balancer.type=lb
worker.status.type=status
worker.balancer.balance_workers=worker1,worker2
worker.balancer.method=B
worker.balancer.sticky_session=True

httpd.conf
---------------

LoadModule jk_module modules/mod_jk.so

<IfModule jk_module>
# Path to workers.properties
JkWorkersFile E:\Apache2.2\conf\workers.properties
# Path to jk logs
JkLogFile E:/Apache2.2/logs/mod_jk.log
# Jk log level [debug/error/info]
JkLogLevel info
# Jk log format
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
# JkOptions for forwarding
JkOptions +ForwardKeySize +ForwardURICompat -ForwardDirectories
# JkRequestLogFormat set the request format
JkRequestLogFormat "%w %V %T"
JkMount /* balancer
JkMount /jkstatus status
</IfModule>

in tomcat server.xml files

Tomcat-1
-------------------------------------
--------------
<Engine name="Catalina" defaultHost="localhost" jvmRoute="worker1">

<Cluster className="org.apache.catalina.ha.tcp.SimpleTcpCluster"
defaultMode="true" />
----------------

Tomcat-2
----------------------

------------
<Engine name="Catalina" defaultHost="localhost" jvmRoute="worker2">

<Cluster className="org.apache.catalina.ha.tcp.SimpleTcpCluster"
defaultMode="true" />

-----------

Am i needed to add any modules (.so files) still or any additional conf is
required???

Thanks :)




On Mon, Nov 4, 2013 at 1:17 PM, Igor Cicimov <icicimov@gmail.com> wrote:

> http://tomcat.apache.org/connectors-doc/reference/workers.html
>
> Did you read this? Did you do the tomcat part of config setting the
> jvmRoute?
> On 04/11/2013 3:13 PM, "Nagaraju Kurma" <nagaraju.kurma@enhancesys.com>
> wrote:
>
>>
>> Hi all,
>>
>> I am new to httpd and using the tomcat hosts behind of httpd. ------>
>> (Apache2.2 and Tomcat-7)
>>
>> i achieved the load balancing perfectly but unable to achieve session
>> replication (sticky session behavior).
>>
>> Due to this i unable to login into application.
>> I noticed like this, At the first request it is pointing to Node-1 and at
>> other request to other like Node-2...etc it seems, so due not having the
>> session replication it is logging out and showing login page.
>>
>> This is my configuration :
>>
>> httpd.conf
>> --------------
>> added new content as part of httpd.conf
>>
>> LoadModule jk_module modules/mod_jk.so
>>
>> <IfModule jk_module>
>> # Path to workers.properties
>> JkWorkersFile E:\Apache2.2\conf\workers.properties
>> # Path to jk logs
>> JkLogFile E:/Apache2.2/logs/mod_jk.log
>> # Jk log level [debug/error/info]
>> JkLogLevel info
>> # Jk log format
>> JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
>> # JkOptions for forwarding
>> JkOptions +ForwardKeySize +ForwardURICompat -ForwardDirectories
>> # JkRequestLogFormat set the request format
>> JkRequestLogFormat "%w %V %T"
>> JkMount /ngcc/* balancer
>> </IfModule>
>>
>> workers.properties
>> --------------------------
>> workers.tomcat_home=E:\Tomcat-A
>> workers.java_home=E:\Java\jdk1.7.0_21
>> #worker.list=worker1,worker2
>> worker.list=balancer
>>
>> worker.worker1.port=2013
>> worker.worker1.host=localhost
>> worker.worker1.type=ajp13
>> worker.worker1.lbfactor=1
>>
>> worker.worker2.port=7080
>> worker.worker2.host=localhost
>> worker.worker2.type=ajp13
>> worker.worker2.lbfactor=1
>> worker.balancer.type=lb
>>
>> worker.balancer.balance_workers=worker1,worker2
>> worker.balancer.method=B
>> # should be routed back to the same #Tomcat worker.
>> worker.balancer.sticky_session=True
>>   (tested with True also)
>>
>> I think there is lack in configuration it seems.... please find out and
>> let me know, any help is appreciated.
>>
>> Thanks & regards
>>
>> Nagaraju
>>
>>
>>
>>


-- 

Thanks & Regards,

Nagaraju K

Mime
View raw message