httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Leighton <jtlei...@udel.edu>
Subject [users@httpd] build issue with old httpd-2.0.55
Date Mon, 11 Nov 2013 21:51:40 GMT
I have a customized version of httpd-2.0.55 that has recently stopped 
building on Ubuntu 10.04 LTS. I know I should move the customization to 
a more recent version of httpd, but that will take some time. The build 
problem isn't related to the customization - the unmodified httpd-2.0.55 
source is also experiencing the same build error. I'm guessing that the 
problem is with some change to my build tools, but I've been unable to 
resolve it. The only configure option I use is --prefix, and make 
completes without error. The problem occurs on make install. Here's the 
tail end of the output from make install, for the unmodified httpd-2.0.55:

.
.
.
cp/testing/install/include/apr_thread_mutex.h' are the same file
cp: `include/apr_thread_proc.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apr_thread_proc.h' 
are the same file
cp: `include/apr_thread_rwlock.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apr_thread_rwlock.h'

are the same file
cp: `include/apr_time.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apr_time.h' 
are the same file
cp: `include/apr_uri.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apr_uri.h' 
are the same file
cp: `include/apr_user.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apr_user.h' 
are the same file
cp: `include/apr_uuid.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apr_uuid.h' 
are the same file
cp: `include/apr_version.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apr_version.h' 
are the same file
cp: `include/apr_want.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apr_want.h' 
are the same file
cp: `include/apr_xlate.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apr_xlate.h' 
are the same file
cp: `include/apr_xml.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apr_xml.h' 
are the same file
cp: `include/apu_compat.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apu_compat.h' 
are the same file
cp: `include/apu.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apu.h' 
are the same file
cp: `include/apu_version.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apu_version.h' 
are the same file
cp: `include/apu_want.h' and 
`/home/leighton/development/apache/2.0.55/tcp/testing/install/include/apu_want.h' 
are the same file
make[1]: *** [install-include] Error 1
make[1]: Leaving directory 
`/home/leighton/development/apache/2.0.55/tcp/testing/install'
make: *** [install-recursive] Error 1
leighton@chablis:~/development/apache/2.0.55/tcp/testing/install$

Thank you for any help with this.

- Jon Leighton

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message