httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yehuda Katz <yeh...@ymkatz.net>
Subject Re: [users@httpd] Apache Virtual Host Config issue
Date Thu, 10 Oct 2013 03:10:18 GMT
On Wed, Oct 9, 2013 at 11:03 PM, Ammar Hassan <amrhsn@live.jp> wrote:

> Thank you for a detailed reply. I have gone through the things you asked
> me to check. There was an entry in netstat -an like this:
>
> TCP    [::]:8080              [::]:0                 LISTENING
>
> Which suggests that Apache is running. So now what I did was, I tried to
> add a Listen directive to the IPAddress the subdomain was resolving to.
>

If that was the only line that matched, apache is only listening on IPv6.


> Listen 123.45.6.789:8080
>
Do you have other listen lines in your configuration?
It might help to enable the server info module and see if there are any
listed in its output.


> I also added a virual host entry explicitly for this IP
> <VirtualHost 123.45.6.789:8080>
> ServerName subdomain.example.com
> </VirtualHost>
>
You should not add a virtual host unless you want it to have different
content or configuration.
Otherwise it will make this harder.


> When I restarted Apache it failed with the following error:
> "Context of the address was (OS 10049) request is invalid. : AH00072:
> make_sock: could not bind to address 123.45.6.789:8080"
>

Are you sure it points to that address? That is not a valid IP address
which would explain why apache can't bind to it.

- Y

Mime
View raw message