httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ammar Hassan <>
Subject RE: [users@httpd] Apache Virtual Host Config issue
Date Wed, 16 Oct 2013 00:15:19 GMT
Hi Vincenzo,

Thanks for the tip, the firewall was up, but even when I disabled that, there was still the
same response. I tried telnet and curl. Curl gives me host resolution error. Telnet connect

When I use the ServerName and localhost from the server the apache is on, it works perfectly.
The domain also works with the IIS on the same machine. Only Apache is not getting requests
from outside, I wonder why.



Date: Tue, 15 Oct 2013 15:24:59 +0200
Subject: Re: [users@httpd] Apache Virtual Host Config issue

Hi Ammar,
if Apache is running on a windows server may be you have a problem with your firewall.Try
to shut it down temporarily.
And don't trust your browser, in many cases it could cache http answers, dns answers and even
negative answers.

Just to be sure you are able to reach your server, you should try from command line a tool
like curl or wget.Even telnet could be used if you know how to do it. 
This should work:

curl -vv -I

2013/10/15 Ammar Hassan <>

Dear Vincenzo,

Thank you for the insight. My IP address is something else I just used as an
example, my server's ip is

Now I have removed the ip from httpd.conf and tried accessing the computer with computer name.

IIS works,

APACHE works if accessed from the machine itself. It does not serve the web page if any other
machine accesses it with machine name.

Why is that?




Date: Mon, 14 Oct 2013 09:58:22 +0200


Subject: Re: [users@httpd] Apache Virtual Host Config issue

Hi Ammar,

usually you don't put "Listen" directive inside your vhost configuration.And you cannot have
an IP address like "IP Addresses are canonically represented in dot-decimal
notation, which consists of four decimal numbers, each ranging from 0 to 255"(

If you what specify an IP address you should choose between the addresses configured on your
server.On the other hand, why do you need to specify a different IP address?

As far as I see now you have your apache up and running on port 8080 and has bind all available
IP addresses. Which for your test should be perfect (IMHO). 

May be your problem is only that you want connect to your server using an IP address not available.
An IP not configured on your server.


On 14/ott/2013, at 01:51, Ammar Hassan <> wrote:

Please help me sort this out. What is it that I am doing wrong here.




Date: Thu, 10 Oct 2013 12:36:29 +0900

Subject: RE: [users@httpd] Apache Virtual Host Config issue


Actually there were two entries as you rightly pointed out.

TCP               LISTENING

TCP    [::]:8080              [::]:0                 LISTENING

The one other Listen directive I have in my httpd.conf is

Listen 8080

Then in vhosts I have


The subdomain is resolving to the IP (the one I mentioned is just an example) the ping is
fine, When I browse the website with localhost:8080 or from LAN ip the site
works perfect.

As a test, I mapped the subdomain on a dummy IIS website, when I browsed it, it worked fine.

When I put 8080 at the end of the domain it says server timed out.




Date: Wed, 9 Oct 2013 23:10:18 -0400


Subject: Re: [users@httpd] Apache Virtual Host Config issue

On Wed, Oct 9, 2013 at 11:03 PM, Ammar Hassan

<<>> wrote:

Thank you for a detailed reply. I have gone through the things you

asked me to check. There was an entry in netstat -an like this:

TCP [::]:8080 [::]:0 LISTENING

Which suggests that Apache is running. So now what I did was, I tried

to add a Listen directive to the IPAddress the subdomain was resolving


If that was the only line that matched, apache is only listening on IPv6.


Do you have other listen lines in your configuration?

It might help to enable the server info module and see if there are any

listed in its output.

I also added a virual host entry explicitly for this IP




You should not add a virtual host unless you want it to have different

content or configuration.

Otherwise it will make this harder.

When I restarted Apache it failed with the following error:

"Context of the address was (OS 10049) request is invalid. : AH00072:

make_sock: could not bind to address"

Are you sure it points to that address? That is not a valid IP address

which would explain why apache can't bind to it.

- Y


To unsubscribe, e-mail:

For additional commands, e-mail:

Vç7V'67&–&R RÖÖ –â W6W'2×Vç7V'67&–&T ‡GG Bæ   6†Ræ÷&pФf÷"
 FF—F–öæ  6öÖÖ æG2 RÖÖ –â W6W'2Ö†VÇ  ‡GG Bæ   6†Ræ÷&pÐ


To unsubscribe, e-mail:

For additional commands, e-mail:

Vincenzo D'Amore
mobile: +39 349 8513251 		 	   		  
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message