httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From trifo <trif...@gmail.com>
Subject [users@httpd] compiling mod_ssl - library mismatch
Date Thu, 19 Sep 2013 09:19:20 GMT
Hi!

 am trying to compile Apache httpd (2.0.65) on AIX 52 and the resources on
your page were a great source of resources so far. But now I am stuck.

We have an older version of httpd (2.0.59) which have to be upgraded now.
The compilation itself succeeded (at last), but I have strange problem with
mod_ssl: it cannot open the standard libc library:

root# ldd /usr/appserver/apache-2.0.65/modules/mod_ssl.so
/usr/appserver/apache-2.0.65/modules/mod_ssl.so needs:
*Cannot findCannot find   /usr/lib/libc.a(shr.o)*
         /unix
         /usr/lib/libcrypt.a(shr.o)


The older version of the same module is able to open the same lib, as you
can see:

root# ldd /usr/appserver/apache-2.0.59/modules/mod_ssl.so
/usr/appserver/apache-2.0.59/modules/mod_ssl.so needs:
         */usr/lib/libc.a(shr.o)*
         /usr/appserver/apache/lib/libgcc_s.a(shr.o)
         /unix
         /usr/lib/libcrypt.a(shr.o)

Can you please help me with any idea to get through this trouble?

Thanks in advance,

--Andras Trifonov

Mime
View raw message