httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rainer M. Canavan" <rainer.cana...@sevenval.com>
Subject Re: [users@httpd] Issues building apache httpd-2.4.6-1.x86_64 on SUSE Linux Enterprise Server 11 (x86_64) - Kindly help
Date Wed, 18 Sep 2013 09:40:55 GMT

On Sep 18, 2013, at 07:53 , Balaji Katika <balaji.katika@gmail.com> wrote:

> 
> blr-3rd-2-dhcp330:~/apache # rpmbuild -ts httpd-2.4.6.tar.bz2 
> error: Failed build dependencies:
>         apr-devel >= 1.4.0 is needed by httpd-2.4.6-1.x86_64
>         apr-util-devel >= 1.4.0 is needed by httpd-2.4.6-1.x86_64
>         openldap-devel is needed by httpd-2.4.6-1.x86_64
>         distcache-devel is needed by httpd-2.4.6-1.x86_64
> 


I've tried building httpd-2.4.6 on CentOS 6 last week, and I had similar
issues. You'll need to build apr, apr-util and distcache RPMs before 
attempting to  build httpd. Apparently openldap is supplied with CentOS, 
so I didn't encounter any problems with that. Find 

The Instructions here at

http://hezachary.wordpress.com/2013/08/09/install-apache-2-4-6-in-centos-6/

should mostly apply to SuSE as well. I have no idea where you should turn to 
find an openldap package, although I suspect that it should be called 
openldap2-devel, and you may have change this in the httpd.spec as well.


rainer

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message