httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jens-U. Mozdzen" <jmozd...@nde.ag>
Subject Re: [users@httpd] Issues building apache httpd-2.4.6-1.x86_64 on SUSE Linux Enterprise Server 11 (x86_64) - Kindly help
Date Wed, 18 Sep 2013 06:52:47 GMT
Hi Balaji,

Zitat von Balaji Katika <balaji.katika@gmail.com>:
> Hi all,
>
> I have downloaded httpd-2.4.6.tar.bz2 from
> http://httpd.apache.org/download.cgi#apache24 onto my SuSE Linux Enterprise
> Server 11 (64-bit) machine (11.2) and trying to build an rpm through it as
> per the instructions mentioned at
> http://httpd.apache.org/docs/2.4/platform/rpm.html
>
> I have resolved the missing -devel packages (several reported earlier like
> pcre,libuuid-devel etc.,). However, I couldn't found the source for the
> below dependencies.
>
>
> *  Is there any readily available rpm for the specific version (or the
> compliant) of SuSE Linux 11.2 ?

please make that "SLES11SP2" - "SuSE Linux 11.2" will typically be  
interpreted as "openSUSE 11.2" :/

There's a build on software.opensuse.org for SP1 and SP3 - the SP1  
version should work:  
https://build.opensuse.org/package/show?project=home%3Acsbuild%3ADBA&package=dba-apache-246

> *  Can someone point me to any apache specific repository for SuSE Linux ?

I again take it as "SuSE Linux Enterprise Server", AKA "SLES" - and  
that platform was created for *stability*, so your best bet will be  
some user build like the one I referenced above. You're leaving the  
supported platform when using such an update, but as "support" is the  
main reason for the enterprise versions of Linux, that is no  
widely-used path.

> *  Any relevant information shall be appreciated ?

Indeed ;)

>
> The repos's mentioned at
> http://en.opensuse.org/Additional_package_repositories#Apache doesn't seem
> to be pointing to a valid URL.

What makes you think so? I just checked two of them, and they take me  
directly to each repository.

> blr-3rd-2-dhcp330:~/apache # rpmbuild -ts httpd-2.4.6.tar.bz2
> error: Failed build dependencies:
>         apr-devel >= 1.4.0 is needed by httpd-2.4.6-1.x86_64
>         apr-util-devel >= 1.4.0 is needed by httpd-2.4.6-1.x86_64
>         openldap-devel is needed by httpd-2.4.6-1.x86_64
>         distcache-devel is needed by httpd-2.4.6-1.x86_64
>
> My zypper is currently referring to the repository
> http://download.opensuse.org/distribution/11.4/repo/oss/suse

That's an openSUSE 11.4 repository - not SLES11SP2. As you can see on  
the page you mention above, no SLES11 repository (for none of the SPs)  
is given... only SLE(S|D)10, which won't help you either :(

Regards,
Jens

PS: You might want to ask that question over at forums.suse.com, too  
(SLES forums, Updates sub-forum) - that's where the SLES folks hang out.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message