httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Reser <...@reser.org>
Subject Re: [users@httpd] RE: EXT :Re: [users@httpd] RE: EXT :Re: [users@httpd] apache 2.2.25 and svn commit
Date Fri, 09 Aug 2013 21:45:13 GMT
On Thu, Aug 1, 2013 at 7:22 PM, Ben Reser <ben@reser.org> wrote:
> On Thu, Aug 1, 2013 at 7:04 PM, Brennan, Edward C (HII-Ingalls)
> <ed.brennan@hii-ingalls.com> wrote:
>> Thanks, Ben.  So based on your response, I still don't know what caused the error.
 I introduced apache 2.2.25 into my environment, and I get the error (which is why I posted
to users@httpd, since I didn't introduce a new subversion).  But when I revert back to apache
2.2.22, I don't get the error.  I assumed the new software introduced the issue.
>
> I actually just tried to replicate the issue with svn 1.6.6 and httpd
> 2.2.25 here and I can't.

My attempt to replicate this must have been wrong because there
clearly is a problem here.  It's being caused by this change:

  *) mod_dav: Ensure URI is correctly uriencoded on return. PR 54611
     [Timothy Wood <tjw omnigroup.com>]

> Well as far as I know this is an unknown issue.  That doesn't mean
> upgrading svn won't fix it, just means I don't think we know about
> this.

Upgrading to new versions of SVN on the server side won't fix the
issue, however if both the client and the server are updated then the
problem will disappear because it only happens when we're using the
DeltaV based communication (referred to SVN devs as HTTPv1) as opposed
to HTTPv2 (no longer DeltaV compliant and specific to SVN).

You can see the problem even with a newer client and server if the
server is configured with:
  SVNAdvertiseV2Protocol off

Still digging to see why that change broke things.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message