httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nourredine Rouibah <nourredine.roui...@gmail.com>
Subject Re: [users@httpd] Re: Apache httpd 2.2.12 hangs
Date Fri, 23 Aug 2013 12:18:17 GMT
Hello,

Resolved.

Thanks for your support Jeff.
We successfully patched our Apache.

We will as well plan an upgrade later this year.

Best,

Nourrédine


On Wed, Aug 21, 2013 at 5:27 PM, Nourredine Rouibah <
nourredine.rouibah@gmail.com> wrote:

> Hi,
>
> Just a confirmation:
>
> - I did apply *only* this patch:
> https://issues.apache.org/bugzilla/show_bug.cgi?id=47645#c13 described in
> the link in comment #13.
>
> I did not apply the other ones mentionned in comments #5 and  #11
> https://issues.apache.org/bugzilla/show_bug.cgi?id=47645#c11
> https://issues.apache.org/bugzilla/show_bug.cgi?id=47645#c5
>
> right ?
>
> thanks,
>
> Nourrédine
>
>
> On Tue, Aug 20, 2013 at 4:57 PM, Jeff Trawick <trawick@gmail.com> wrote:
>
>> On Tue, Aug 20, 2013 at 10:40 AM, Nourredine Rouibah <
>> nourredine.rouibah@gmail.com> wrote:
>>
>>> Hi,
>>>
>>> After rebuilding Apache with the patch on port.c, is it correct to just
>>> replace libapr-1.so.0.3.7
>>>  in the running apache installation ? That would speed up the fix.
>>>
>>
>> You have to
>>
>> * make a backup copy of the library
>> * stop httpd
>> * replace the library
>> * start httpd again.
>>
>> Since it hangs intermittently anyway, pretend it is hung and has to be
>> restarted ;)
>>
>>
>>>
>>> thanks,
>>>
>>> /Nourrédine.
>>>
>>>
>>> On Tue, Aug 20, 2013 at 2:51 PM, Jeff Trawick <trawick@gmail.com> wrote:
>>>
>>>> On Tue, Aug 20, 2013 at 8:00 AM, Nourredine Rouibah <
>>>> nourredine.rouibah@gmail.com> wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> After doing some search I suspect our problems to be related with this
>>>>> issue : https://issues.apache.org/bugzilla/show_bug.cgi?id=47645
>>>>>
>>>>> I say that because the problem started to happen as soon as we changed
>>>>> our Solaris HW to a new one.
>>>>> Before that, we experienced http hang outs but once every 3 months and
>>>>> a restart did solve the issue.
>>>>> Since we moved to the new HW (same Solaris version) we httpd hangs
>>>>> many times per day.
>>>>>
>>>>> As I described, the port 20000 hangs and a request to port 20001 did
>>>>> release the httpd.
>>>>>
>>>>> Can someone confirm that it worth trying to rebuild with the above
>>>>> patch ?
>>>>>
>>>>
>>>> yes, it is worth getting that fix to try to resolve unresponsive
>>>> behavior on Solaris with multiple listening sockets and a server that is
>>>> not at max connections
>>>>
>>>> please just update the bloody software ;)    that bug is ancient history
>>>>
>>>> (good work on the bug research; I had forgotten about that)
>>>>
>>>>
>>>
>>>
>>> --
>>> Nourredine Rouibah
>>> nourredine.rouibah@gmail.com
>>>
>>
>>
>>
>> --
>> Born in Roswell... married an alien...
>> http://emptyhammock.com/
>>
>
>
>
> --
> Nourredine Rouibah
> nourredine.rouibah@gmail.com
>



-- 
Nourredine Rouibah
nourredine.rouibah@gmail.com

Mime
View raw message