httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From LuKreme <krem...@kreme.com>
Subject [users@httpd] Re: Broken includes and cgis with Apache 2.4 update
Date Mon, 05 Aug 2013 20:48:05 GMT
On 04 Aug 2013, at 23:19 , LuKreme <kremels@kreme.com> wrote:
> I have a site with the following .htaccess:
> 
> Options +ExecCGI +Includes
> AddType text/html .shtml
> AddOutputFilter INCLUDES .shtml
> AddType application/x-httpd-cgi .cgi/
> AddType application/x-httpd-cgi .pl
> AddType application/x-httpd-cgi .pl/
> AddType text/css .css
> 
> I also have Addtype and AddOutputFilter lines in the httpd.conf (in the ifmodule mime_module,
as well as the following block:
> 
> <Directory "/usr/local/www">
> Options +Indexes +FollowSymLinks +Includes -SymLinksIfOwnerMatch
> AllowOverride All
> Require all granted
> </Directory>
> 
> and on the index.shtml page I have
> 
> <div class=purple>
> <!--#include file="menu.inc"-->
> </div>
> 
> This all worked in apache 2.2 (with AddHandler server-parsed .shtml), but under 24 the
menu.inc file is not
> loading. Since the content of the site has not changed in 11 years, so this is definitely
something I've missed in the Apache configuration for 2.4.
> 
> Also, none of the .pl files are being executed, instead just displaying their source.

any ideas? I'm pretty stuck.

-- 
gentlemen in England now a-bed Shall think themselves accursed the were
not here,


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message