httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dweimer <dwei...@dweimer.net>
Subject [users@httpd] Apache 2.4 authentication issue
Date Tue, 09 Jul 2013 15:21:05 GMT
I have updated my second server from Apache 2.2.x to Apache 2.4.x, first 
server went fine with no problems.  The second server however is having 
difficulty with a few directories that I had password protected with 
basic authentication.  I am using Apache 2.4.4 as its the current port 
on FreeBSD, and I am aware of the htpasswd bug in that version, and have 
confirmed its not the cause of my problem, in fact I tried switching 
over to digest authentication with the same result.

I have the directives configured as follows.

<Directory "/usr/local/www/apache24/data">
   Options Indexes FollowSymLinks
   AllowOverride None
   Require all granted
</Directory>

<FilesMatch "^\.ht">
   Require all denied
</FilesMatch>

<Directory "/usr/local/www/apache24/data/sarg">
   SSLRequireSSL
   Require all denied
   AuthType basic
   AuthBasicProvider file
   AuthName "SARG"
   AuthUserFile /usr/local/www/apache24/data/sarg/.htpasswd
   Require valid-user
</Directory>

I don't get any errors, just a login loop, doesn't matter if I use a 
valid username password combination or invalid, I can even move the 
.htpasswd file out of the folder which should cause an error, but no 
error ever gets logged even with debugging on.

The only log I get is the entry showing me the get request that was 
marked as 401 unauthenticated:
[09/Jul/2013:09:41:16 -0500] "GET /sarg/index.html HTTP/1.1" 401 381

Does anyone have any clue what I could be missing?

-- 
Thanks,
    Dean E. Weimer
    http://www.dweimer.net/

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message