httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ismael Puerto <ismael.pue...@seres.es>
Subject Re: [users@httpd] Apache Upgrade Question ...
Date Thu, 11 Apr 2013 07:44:10 GMT
Hi Rajesh

This is my step for build apache with OpenSSL from sources for PCI DSS

tar -zxvf openssl-1.0.1e.tar.gz && tar -zxvf httpd-2.2.24.tar.gz

cd openssl-1.0.1e
./config -fPIC --install_prefix=/usr/local/openssl-1.0.1e
make
make install

useradd -s /bin/false apache
cd httpd-2.2.24

export LDFLAGS=-ldl
./configure --prefix=/usr/local/httpd-2.2.24 --enable-ssl \
--with-ssl=/usr/local/openssl-1.0.1e/usr/local/ssl --enable-rewrite \
--enable-mods-shared=all --with-included-apr \
--disable-dav --disable-dav-fs --disable-dav-lock
make
make install

Config apache:

SSLProtocol -ALL +SSLv3 +TLSv1.1 +TLSv1.2
SSLHonorCipherOrder on
SSLCipherSuite
ECDHE-RSA-AES128-SHA256:AES128-GCM-SHA256:RC4:HIGH:!MD5:!aNULL:!EDH

TraceEnable off

ServerTokens Prod

I hope that this it can help you

Best Regards

On 11/04/13 00:44, CR Rajesh wrote:
> 
> Hello,
> 
>       I'm currently running Apache version Apache/2.2.11 in Ubuntu 9.04.
> I want to update this to atleast Apache 2.2.24 for PCI compliance.
> 
> Can you help me in getting the instructions for a safe and successful
> upgrade?
> 
> Thanks,
> Rajesh.
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message