httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian C <mc_...@yahoo.com>
Subject [users@httpd] Query Str
Date Mon, 15 Apr 2013 17:49:57 GMT
Sorry for reposting but I'm still stumped.  If anyone has any advice at all...

thanks


Hi everyone,

I'm new to web configurations etc. I hope someone can help me with this, I've been googling
and reading docs for many hours.

I have Apache 2.2.19 which has been running fine, until I needed a new CGI which needed the
QUERY_STRING from the Get (eg.
 <url>?SBC=A1... ) My CGI can obtain all other pertinent env vars, in fact here they
 are:

DOCUMENT_ROOT'='/usr/pkg/share/httpd/htdocs'\n
GATEWAY_INTERFACE'='CGI/1.1'\n
HTTP_ACCEPT'='text/event-stream'\n
HTTP_ACCEPT_ENCODING'='gzip, deflate'\n
HTTP_ACCEPT_LANGUAGE'='en-US,en;q=0.5'\n
HTTP_CONNECTION'='keep-alive'\n
HTTP_HOST'='10.128.29.39'\n
HTTP_USER_AGENT'='Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
 FirePHP/0.7.1'\n
PATH'='/usr/pkg/...[SNIP]'\n
QUERY_STRING'=''\n
REMOTE_ADDR'='10.128.29.148'\n
REMOTE_PORT'='11324'\n
REQUEST_METHOD'='GET'\n
REQUEST_URI'='/cgi-bin/SBC.cgi'\n
SCRIPT_FILENAME'='/usr/pkg/share/httpd/htdocs/JC84/cgi-bin/SBC.cgi'\n
SCRIPT_NAME'='/cgi-bin/SBC.cgi'\n
SERVER_ADDR'='10.128.29.39'\n
SERVER_ADMIN'='mc_ian@yahoo.com'\n
SERVER_NAME'='10.128.29.39'\n
SERVER_PORT'='80'\n
SERVER_PROTOCOL'='HTTP/1.1'\n
SERVER_SIGNATURE'=''\n
SERVER_SOFTWARE'='Apache/2.2.19 (Unix) mod_ssl/2.2.19 OpenSSL/0.9.8m DAV/2'\n"

See? No Query_String!

Apache does receive the request ok according to this log:

# grep "SBC=A1" /var/log/httpd/access_log
...29.148 - - [11/Apr/2013:23:13:10 -0400] "GET /JC84/SBCs.html?SBC=A1 HTTP/1.1" 304 -
Mime
View raw message