httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yehuda Katz <yeh...@ymkatz.net>
Subject Re: [users@httpd] VirtualHost configuration not working as expected with ePages solution
Date Thu, 03 Jan 2013 14:45:57 GMT
On Thu, Jan 3, 2013 at 9:01 AM, Tom Frost <fro5tie@yahoo.com> wrote:

> Just to clarify, this is how the conf files look now:
>
> httpd.conf:
>
> NameVirtualHost *:80
>
> <VirtualHost *:80>
>
> DocumentRoot /var/www/html/path/
> ServerName url2.mydomain.com
> ServerAlias url2.mydomain.com
> </VirtualHost>
>
> epages.conf:
>
> <IfDefine PROXY>
> <VirtualHost *:80>
> ServerName url1.mydomain.com
> ServerAlias url1.mydomain.com
> <Location /epages/>
>     <IfDefine LB>
>         ProxyPass balancer://cluster/epages/
>         ProxyPassReverse balancer://cluster/epages/
>     </IfDefine>
>     <IfDefine !LB>
>         ProxyPass http://url1.mydomain.com:8008/epages/
>         ProxyPassReverse http://url1.mydomain.com:8008/epages/
>     </IfDefine>
> </Location>
> </VirtualHost>
> </IfDefine>


I believe which ever VHOST config file is included first will become the
default (although most of my experience in that regard is from the
Debian/Ubuntu versions which might be different).
In Ubuntu, you usually name the file with the default vhost starting with
000- to make sure it is included first.
NameVirtualHost should be before any vhost is included. On my server it is
in /etc/apache2/ports.conf which is included before any VHOSTs.

Mime
View raw message