httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Cicimov <icici...@gmail.com>
Subject Re: [users@httpd] Apache fails to start when mod_deflate is enabled
Date Wed, 09 Jan 2013 08:13:48 GMT
On 09/01/2013 6:14 PM, "Abhi Auradkar" <aurabhi@yahoo.com> wrote:
>
> Hi,
>
> Probing further I see that mod_deflate is having some problems.. and
zcalloc, zcfree etc.. which seem like related zlib. I may be wrong here.
Your thoughts?
>
> bash-3.2# ldd -r /usr/local/apache2/modules/mod_deflate.so
>         libc.so.1 =>     /lib/64/libc.so.1
> ld.so.1: lddstub: fatal: relocation error: R_AMD64_32: file
/usr/local/apache2/modules/mod_deflate.so: symbol zcalloc: value
0xfffffd7fff343880 does not fit
> ld.so.1: lddstub: fatal: relocation error: R_AMD64_32: file
/usr/local/apache2/modules/mod_deflate.so: symbol zcalloc: value
0xfffffd7fff343880 does not fit
> ld.so.1: lddstub: fatal: relocation error: R_AMD64_32: file
/usr/local/apache2/modules/mod_deflate.so: symbol zcfree: value
0xfffffd7fff3438e0 does not fit
> ld.so.1: lddstub: fatal: relocation error: R_AMD64_32: file
/usr/local/apache2/modules/mod_deflate.so: symbol zcfree: value
0xfffffd7fff3438e0 does not fit
>
>


Did you maybe compiled apache on SPARC and moved to AMD64 machine? Did
apache run without errors on the compile box? Maybe this can help
explaining why you are seeing the error:

https://blogs.oracle.com/rie/entry/my_relocations_don_t_fit<https://blogs.oracle.com/rie/entry/my_relocations_don_t_fit#>

> Thanks,
>
> ________________________________
> From: Igor Cicimov <icicimov@gmail.com>
> To: users <users@httpd.apache.org>; Abhi Auradkar <aurabhi@yahoo.com>
> Sent: Wednesday, January 9, 2013 12:02 PM
>
> Subject: Re: [users@httpd] Apache fails to start when mod_deflate is
enabled
>
>
>
>
> On Wed, Jan 9, 2013 at 5:14 PM, Abhi Auradkar <aurabhi@yahoo.com> wrote:
>>
>> Hi,
>>
>> I am trying to get the details for the machine on which it was built.
>> Meanwhile my concern is while the apache runs fine when mod_deflate is
disabled.
>> Has it got to do something with the libz on the machine?
>>
>>
> Hmm very possibly. I would run ldd against httpd binary and compare the
lib versions of all the libs apache is linked to with the ones on the build
machine, starting with libz.
>
>
>>
>> Thanks,
>>
>> ________________________________
>> From: Igor Cicimov <icicimov@gmail.com>
>> To: users <users@httpd.apache.org>; Abhi Auradkar <aurabhi@yahoo.com>
>> Sent: Wednesday, January 9, 2013 11:19 AM
>>
>> Subject: Re: [users@httpd] Apache fails to start when mod_deflate is
enabled
>>
>>
>>
>>
>> On Wed, Jan 9, 2013 at 4:30 PM, Abhi Auradkar <aurabhi@yahoo.com> wrote:
>>>
>>> Hi,
>>>
>>> This apache is compiled from source. It was compiled on another machine
though.
>>
>>
>> In that case both boxes have to be completely identical, same hardware
and software structure. Was the other box maybe 32 bit machine?
>>
>>>
>>>
>>> This is what the file and ldd result in. (The libraries refered are
present in /lib/64)
>>>
>>> bash-3.2# file /usr/local/apache2/modules/mod_deflate.so
>>> /usr/local/apache2/modules/mod_deflate.so:       ELF 64-bit LSB dynamic
lib AMD64 Version 1 [SSE CMOV], dynamically linked, not stripped
>>>
>>> bash-3.2#ldd usr/local/apache2/modules/mod_deflate.so
>>> libc.so.1 =>     /lib/64/libc.so.1
>>> libm.so.2 =>     /lib/64/libm.so.2
>>>
>>>
>>> Thanks,
>>>
>>>
>>> ________________________________
>>> From: Igor Cicimov <icicimov@gmail.com>
>>> To: users <users@httpd.apache.org>; Abhi Auradkar <aurabhi@yahoo.com>
>>> Sent: Wednesday, January 9, 2013 4:55 AM
>>> Subject: Re: [users@httpd] Apache fails to start when mod_deflate is
enabled
>>>
>>>
>>> On Tue, Jan 8, 2013 at 11:01 PM, Abhi Auradkar <aurabhi@yahoo.com>
wrote:
>>>>
>>>> Hi,
>>>>
>>>> On a solaris AMD64 bit machine the apache server fails to start when
mod_deflate is enabled.
>>>> Following is the error that I see.
>>>>
>>>> httpd: Syntax error on line 934 of /usr/local/apache2/conf/httpd.conf:
Syntax error on line 5 of
>>>> /usr/local/apache2/conf/modules.conf: Cannot load
/usr/local/apache2/modules/mod_deflate.so into
>>>> server: ld.so.1: httpd: fatal: relocation error: R_AMD64_PC32: file
/usr/local/apache2/modules/mod_deflate.so: symbol memset: value
0x28001baf05a does not fit
>>>>
>>>>
>>>> Machine Details
>>>> ---------------
>>>> SunOS pearl 5.10 Generic_142910-17 i86pc i386 i86pc
>>>>
>>>> 64-bit amd64 applications
>>>>         sse4.2 sse4.1 ssse3 popcnt tscp cx16 mon sse3 pause sse2 sse
fxsr mmx
>>>>         cmov amd_sysc cx8 tsc fpu
>>>> 32-bit i386 applications
>>>>         sse4.2 sse4.1 ssse3 popcnt tscp cx16 mon sse3 pause sse2 sse
fxsr mmx
>>>>         cmov sep cx8 tsc fpu
>>>>
>>>>
>>>>
>>>> Any pointers whats wrong here.
>>>>
>>>> Appreciate your help!
>>>>
>>>> Thanks,
>>>
>>>
>>> First how did you install apache, using Solaris binary or compiled from
source? Second, post the output of:
>>>
>>> $ file /usr/local/apache2/modules/mod_deflate.so
>>> $ ldd /usr/local/apache2/modules/mod_deflate.so
>>>
>>>
>>>
>>
>>
>>
>
>
>

Mime
View raw message