httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Rottermann <robert.rotterm...@gmx.ch>
Subject [users@httpd] question with apache rewriterules (working using crome, but not FF)
Date Sat, 12 Jan 2013 15:19:32 GMT
Hi there,
we are about to go live with a site we reimplemented.
The site structure is different between the two sites.

What I now would like to do is that old content is fetched from the old
site.
This I try to do with apache redirect rules:

Here they are:
    #--------------------
    # old site
    #--------------------
    RewriteRule ^/web(.*) http://127.0.0.1:8181/VirtualHostBase/http/%{SERVER_NAME}:80/ecweb/ecweb/web/VirtualHostRoot/$1
[L,P,R]
    ...

    #--------------------
    # new site
    #--------------------
    RewriteRule /(.*)/$ http://127.0.0.1:8192/VirtualHostBase/http/%{SERVER_NAME}:80/ecweb/ecweb5/VirtualHostRoot/$1
[L,P,R]
    RewriteRule ^/(.*) http://127.0.0.1:8192/VirtualHostBase/http/%{SERVER_NAME}:80/ecweb/ecweb5/VirtualHostRoot/$1
[L,P,R]

Now this works fine using google chrome V23 and safari (version unknown), but fails on firefox
and IE

you can try it yourself with:
http://www.energie-cluster.ch
http://www.energie-cluster.ch/web

I do not have yet a proxy (like varnish) installed

thanks for any pointers
robert



------------------------------------------------------------------------------
Master Visual Studio, SharePoint, SQL, ASP.NET, C# 2012, HTML5, CSS,
MVC, Windows 8 Apps, JavaScript and much more. Keep your skills current
with LearnDevNow - 3,200 step-by-step video tutorials by Microsoft
MVPs and experts. SALE $99.99 this month only -- learn more at:
http://p.sf.net/sfu/learnmore_122912
_______________________________________________
Plone-Users mailing list
Plone-Users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/plone-users


Mime
View raw message