httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Frost <fro5...@yahoo.com>
Subject Re: [users@httpd] VirtualHost configuration not working as expected with ePages solution
Date Fri, 04 Jan 2013 16:19:10 GMT
Hi

Sorry for the delayed reply. epages.conf is included right at the bottom of httpd.conf, as
below:

Include /etc/httpd/conf.d/zzz-epages-*.conf


I'll b e honest, I'm not 100% sure about all the IfDefine stuff, all the epages configs are
created when you install the package. I would like to not change them if possible, but I have
tried commenting out the IfDefine tags around the VirtualHost, and still to no avail.

Thanks again


________________________________
 From: Igor Cicimov <icicimov@gmail.com>
To: users <users@httpd.apache.org> 
Sent: Thursday, 3 January 2013, 22:24
Subject: Re: [users@httpd] VirtualHost configuration not working as expected with ePages solution
 


On 04/01/2013 1:02 AM, "Tom Frost" <fro5tie@yahoo.com> wrote:
>
> Just to clarify, this is how the conf files look now:
>
> httpd.conf:
>
> NameVirtualHost *:80
>
> <VirtualHost *:80>
>
> DocumentRoot /var/www/html/path/
> ServerName url2.mydomain.com
> ServerAlias url2.mydomain.com
> </VirtualHost>
>
> epages.conf:
>
> <IfDefine PROXY>
> <VirtualHost *:80>
> ServerName url1.mydomain.com
> ServerAlias url1.mydomain.com
> <Location /epages/>
>     <IfDefine LB>
>         ProxyPass balancer://cluster/epages/
>         ProxyPassReverse balancer://cluster/epages/
>     </IfDefine>
>     <IfDefine !LB>
>         ProxyPass http://url1.mydomain.com:8008/epages/
>         ProxyPassReverse http://url1.mydomain.com:8008/epages/
>     </IfDefine>
> </Location>
> </VirtualHost>
> </IfDefine>
>
> _____
1. Where and how is epages.conf included in the main config?
2. What are PROXY and LB? If they are what I think they are you need to start apache with
-DPROXY switch or that vhost will not be active at all due to IfDefine condition

___________________________
> From: Tom Frost <fro5tie@yahoo.com>
> To: "users@httpd.apache.org" <users@httpd.apache.org>
> Sent: Thursday, 3 January 2013, 13:58
> Subject: Re: [users@httpd] VirtualHost configuration not working as expected with ePages
solution
>
>
> Hi
>
> I have changed both VirtualHost definitions to *:80 and NameVirtualHost has the same,
however both whichever hostname I use I still get the same site. Does it matter that the VirtualHost
definitions are in separate config files?
>
> Thanks again
>
>
> ________________________________
> From: Eric Covener <covener@gmail.com>
> To: users@httpd.apache.org; Tom Frost <fro5tie@yahoo.com>
> Sent: Thursday, 3 January 2013, 12:02
> Subject: Re: [users@httpd] VirtualHost configuration not working as expected with ePages
solution
>
> > <VirtualHost _default_:80>
> > <VirtualHost
> my.ip.add.res:80>
>
> These have to be the identicalvalues for name-based vhosts to treat
> them as part of a set.
>
> If you don't care what IP address is used, use *:80 for both. If you
> do care, use t my.ip.add.res:80 for both.  NameVirtualHost should have
> again an identical argument.
>
> --
> Eric Covener
> covener@gmail.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
Mime
View raw message