httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Frost <fro5...@yahoo.com>
Subject [users@httpd] VirtualHost configuration not working as expected with ePages solution
Date Thu, 03 Jan 2013 11:24:13 GMT
Hi
I have a Centos server running ePages (which runs on Apache). Now I want to use the same server
to host a couple of other sites as well, but I can't seem to get my configs working correctly.
I'm not sure if anyone is familiar with epages (I've looked on their forums to no avail),
but this is the epages bit of the config:

<VirtualHost _default_:80>
<Location /epages/>
<IfDefine LB> ProxyPass balancer://cluster/epages/ ProxyPassReverse balancer://cluster/epages/
</IfDefine>
<IfDefine !LB> ProxyPass http://myinternal.url:8008/epages/ ProxyPassReverse http://myinternal.url:8008/epages/
</IfDefine>
</Location>
</VirtualHost> 
and this is what I've added
<VirtualHost my.ip.add.res:80> DocumentRoot /var/www/html/path/
ServerName another.url.com
ServerAlias another.url.com </VirtualHost> 
Now I was under the impression that any request to "another.url.com" will go to the DocumentRoot
which I have added, and any other request will go to the default which epages will handle.
However, no matter how I go to the server, with any of the URLs pointing to it, it always
goes to the new vhost which I have added, and never goes to epages anymore.
I don't want to change the epages configuration if possible, can anyone shed any light as
to what's happening here?
There is a lot more to the epages configurations, but not related to VirtualHosts so I havent
pasted it, but if I need to then let me know.
Thanks in advance for any help
Tom

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message