httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thibaut Lemaire <tib1av...@gmail.com>
Subject Re: [users@httpd] DEFLATE after Substitute on Apache Proxy Server
Date Wed, 19 Dec 2012 09:16:06 GMT
Le 18/12/2012 20:30, Nick Kew a écrit
> Something in your setup is failing to set the right headers
> to describe the contents returned.
>
> Apart from looking for clues in the error log, you could
> diagnose it starting by looking at exactly what gets
> sent to the browser.  Or you could post a URL that
> illustrates the problem, so we could check it out.
>

You can see the problem on this url :
http://test2.titag.com/

Actual configuration is :

ExtFilterDefine FAnalyse mode=output intype=text/html 
cmd="/home/dev/analyse"

<VirtualHost *:80>
         ServerName test2.titag.com
         <Location />
                 ProxyPass http://www.titag.com/
                 SetOutputFilter INFLATE;FAnalyse;DEFLATE
                 #Header append Vary User-Agent env=!dont-vary
         </Location>
</VirtualHost>


Response Headers are :

Connection 	|Keep-Alive|
Content-Type 	|text/html|
Date 	|Wed, 19 Dec 2012 09:15:08 GMT|
Keep-Alive 	|timeout=15, max=100|
Last-Modified 	|Wed, 31 Oct 2012 10:25:08 GMT|
Server 	|nginx/1.2.5|
Transfer-Encoding 	|chunked|
Vary 	|User-Agent|



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message