httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Radosław Smogura <m...@smogura.eu>
Subject [users@httpd] ProxyPass and authentication
Date Sat, 03 Nov 2012 17:39:17 GMT
Hello,

I have problem with access to /svn-rs path - I get 404 not found page 
from Glassfish server instead of authentication request from Apache.
Checking with FireBug I see headers WWW-Authenticate Basic realm="My 
realm", and in addition Powered-By	Servlet/3.0 JSP/2.2
for Glassfish's 404.

In addition I don't see my requests are logged as well in Apache logs, 
and Glassfish ones.

Here are snips of my config

<VirtualHost 217.118.26.142:
ServerName X
ServerAlias X Y Z
UseCanonicalName off
SetOutputFilter deflate

#Snips logging and SSL

ProxyPass /svn-rs !
ProxyPass / balancer://cluster-1-ajp-s/
ProxyPassReverse / balancer://cluster-1-ajp-s/

<Location /svn-rs>
SetOutputFilter DEFLATE
DAV svn
SVNParentPath /srv/svn-rs

AuthType Basic
Require ldap-dn DN
#Snips
</Location>
</VirtualHost>

When I comment ProxyPass / ajp:// or I will down Glassfish everything 
works as expected.

I haven't used this path for some time, but I'm sure it was working on 
1th April 2012 (I checked in logs), today this stopped to work.

Can someone explain me what I do wrong?

Kind regards,
Radosław Smogura


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message