httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Welsh, Neil" <welsh...@visa.com>
Subject RE: [users@httpd] Mod_wsgi
Date Fri, 19 Oct 2012 15:01:50 GMT
Hi,

Thanks for that.  I have updated my path to include my Python install 'PATH=c:\Python26;....'
thank you for that.  But I still get the same error.
Im not too sure what you meant by 'bin\httpd' after setting the path (sorry I feel very stupid
at the moment)

My Python is a 32 bit version...(I don't have a 64 bit machine)

Cheers,
Neil


Neil Welsh│Ab Initio Development | Visa Europe │T + 44 (0) 1189 9397431 │
www.visaeurope.com
 
ABOUT VISA EUROPE - Visa Europe is a membership association of more than 4,000 European banks
and payment institutions. As a payment technology business, we provide the brand, systems,
services and operating rules that make electronic payments between millions of European consumers,
retailers, businesses and governments happen.  We continually invest and innovate, creating
new and better ways to pay and be paid. We make money flow.  For more information, please
contact us.
 
P Please consider the environment before printing this email

-----Original Message-----
From: Jeff Trawick [mailto:trawick@gmail.com] 
Sent: 19 October 2012 15:46
To: users@httpd.apache.org
Subject: Re: [users@httpd] Mod_wsgi

On Fri, Oct 19, 2012 at 10:28 AM, Welsh, Neil <welshnei@visa.com> wrote:
> Hi,
>
> I am relatively new to Apache so im sorry if this is a silly question, but
> :)....I am having issues loading the Mod_wsgi.so file on my windows xp
> Apache server.  I get the following error messages:
>
> httpd.exe: Syntax error on line 129 of C:/Program Files/Apache Software
> Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/Program Files/Apache
> Software Foundation/Apache2.2/modules/mod_wsgi.so into server: The specified
> module could not be found.

A likely cause is that it can't find the python .dll.

>
> I am using Apache 2.2 with Python 2.6 and I downloaded
> mod_wsgi-win32-ap22py26-3.3.so....any help would be greatly appreciated im
> at a dead end.  I have looked through the archives here and I have tried
> reinstalling my python version to make sure it was installed for everyone
> (and the file is their it was the first thing I checked :) )

That mod_wsgi binary is 32-bit, and your Apache httpd is 32-bit
(presumably).  Did you install 32-bit Python?

This works from me from a command Window:

set PATH=c:\python27-32bit;%PATH%
bin\httpd

(I haven't updated any global settings so that the 32-bit Python dll
is always findable.)

Without the 32-bit Python directory in the path I get the same symptom as you.

Obviously this won't make Python findable in other environments, but
it is a start.


>
> Cheer,
> Neil
>
> Neil Welsh│Ab Initio Development | Visa Europe │T + 44 (0) 1189 9397431 │
> www.visaeurope.com
>
> ABOUT VISA EUROPE - Visa Europe is a membership association of more than
> 4,000 European banks and payment institutions. As a payment technology
> business, we provide the brand, systems, services and operating rules that
> make electronic payments between millions of European consumers, retailers,
> businesses and governments happen.  We continually invest and innovate,
> creating new and better ways to pay and be paid. We make money flow.  For
> more information, please contact us.
>
> P Please consider the environment before printing this email
>



-- 
Born in Roswell... married an alien...
http://emptyhammock.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message