httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bhattacharya, Sudip" <sudip.bhattacha...@genpact.com>
Subject [users@httpd] How to debug SetEnvIfNoCase command?
Date Fri, 26 Oct 2012 15:17:21 GMT
Hi,

I am facing issues with SetEnvIfNoCase command. Can you help me on how to debug it? I have
set my log level to debug, but not seeing any evaluation details there.

The problem I am facing is with the below set of commands.

#enable gzip for all
SetOutputFilter DEFLATE
#assume that user is local
SetEnv UserIs=local
#check for custom header "RemoteUser=remote" set by remote proxy apache, to check if user
is local or coming via remote apache proxy.
#this condition is running even if the RemoteUser http header is not present in the request
SetEnvIfNoCase RemoteUser remote !UserIs
#disable gzip for local users, it should run only for remote users
SetEnvIfNoCase UserIs local no-gzip dont-vary

Stragely, all users are getting gzipped data. While I feel the above commands should disable
gzip if users are local.
What am I doing wrong?

______________________________
Sudip Kumar Bhattacharya



This e-mail (and any attachments), is confidential and may be privileged. It may be read,
copied and used only
by intended recipients. Unauthorized access to this e-mail (or attachments) and disclosure
or copying of its 
contents or any action taken in reliance on it is unlawful. Unintended recipients must notify
the sender immediately 
by e-mail/phone & delete it from their system without making any copies or disclosing
it to a third person.

Mime
View raw message