httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Prabhjot Kaur -X (prakaur - Aricent Technologies at Cisco)" <prak...@cisco.com>
Subject [users@httpd] Unable to launch the application
Date Mon, 22 Oct 2012 05:21:07 GMT
Hi Friends

I am trying to launch a simple Hello World program using Hello.jar file.
I get "Unable to launch the Application Error" and the following Exception is shown:

java.lang.ClassNotFoundException: Hello
                at java.net.URLClassLoader$1.run(Unknown Source)
                at java.net.URLClassLoader$1.run(Unknown Source)
                at java.security.AccessController.doPrivileged(Native Method)
                at java.net.URLClassLoader.findClass(Unknown Source)
                at com.sun.jnlp.JNLPClassLoader.findClass(Unknown Source)
                at java.lang.ClassLoader.loadClass(Unknown Source)
                at java.lang.ClassLoader.loadClass(Unknown Source)
                at com.sun.javaws.Launcher.doLaunchApp(Unknown Source)
                at com.sun.javaws.Launcher.run(Unknown Source)
                at java.lang.Thread.run(Unknown Source)


I am new user of Apache so don't know much details. To me the above error seems like Web Server
is not able to locate the path for Hello class.
But I have defined the path for this application in httpf.conf using <Directory > directive.
Also defined alias for this too.

Can anyone please help me on this issue why it Apache Webserver is not launching the application.

The snippet of code where the jar file is requested is given below:

#define LauncherWebStart "\n"                                              \
                            "<?xml version=\"1.0\" encoding="                 \
                            "\"UTF-8\"?>\n"                                   \
                            "<jnlp spec=\"1.0+\" codebase=\"http://10.78.161.61:8090/var/www/jars/\">\n"
   \
                            "  <information>\n"                               \
                            "    <title>Hello Launcher</title>\n"            
  \
                            "    <vendor>Hello Systems</vendor>\n"       \
                            "    <description>Browser-based launcher for "    \
                            "Hello</description>\n"                             \
                            "    <description kind=\"tooltip\">Hello "          \
                            "Launcher</description>\n"                        \
                            "    <icon kind=\"world2\" href="                 \
                            "\"/icons/world2.gif\" />\n"                          \
                            "  </information>\n"                              \
                            "  <resources>\n"                                 \
                            "    <jar href=\"Hello.jar\" />\n"           \
                            "  <j2se version=\"1.6+\" />\n"                 \
                            "  </resources>\n"                                \
                            "  <security>\n"                                  \
                            "    <all-permissions/>\n"                        \
                            "  </security>\n"                                 \
                            "  <application-desc main-class=\"Hello\" />\n"   \
                            "</jnlp>\n"

Since last few days I am struck with the same problem. Please help me resolving the same.

Thanks & Regards
Prabhjot

Mime
View raw message