httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brad Baker" <Brad.Ba...@xtra.ca>
Subject RE: [users@httpd] Apache on Windows NFS Mount
Date Fri, 28 Sep 2012 21:06:34 GMT
"When running Apache httpd as a service, you must create a separate
account in order to access network resources, as described above."

I've already done this per my original post: " I'm running apache as an
active directory account (ourdomain\apache)". I can access the resource
as the apache user (at least interactively). Perhaps the issue is
interactive vs non-interactively accessing it?



-----Original Message-----
From: Jeff Trawick [mailto:trawick@gmail.com] 
Sent: Friday, September 28, 2012 4:55 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Apache on Windows NFS Mount

On Fri, Sep 28, 2012 at 4:50 PM, Brad Baker <Brad.Baker@xtra.ca> wrote:
> Thanks but this is for UNC/SMB/CIFS (which I already have working - 
> albeit performance is awful). I'm trying to use NFS.

It seems that you have some shared symptoms -- the service environment
you're using isn't aware of that mapped drive.

"When running Apache httpd as a service, you must create a separate
account in order to access network resources, as described above."

Good luck either way...

>
>
> -----Original Message-----
> From: Jeff Trawick [mailto:trawick@gmail.com]
> Sent: Friday, September 28, 2012 3:55 PM
> To: users@httpd.apache.org
> Subject: Re: [users@httpd] Apache on Windows NFS Mount
>
> On Fri, Sep 28, 2012 at 3:42 PM, Brad Baker <Brad.Baker@xtra.ca>
wrote:
>> I'm trying to get apache on windows 2008 R2 to work with an NFS mount

>> as the document root. I have done the following:
>
> See if this helps:
>
> http://httpd.apache.org/docs/2.4/platform/windows.html#windrivemap
>>
>>
>>
>> - Setup Services for Network File System
>>
>> - Ran the following commands (again on windows): mount 
>> \\10.99.108.90\test_htdocs X:
>>
>> - I can open my computer and browse the X: drive, create files.
>>
>> - I open up httpd.conf and change my configuration as such:
>>
>>         DocumentRoot "X:/new"
>>
>>         <Directory "X:/new">
>>
>> - I fire up the apache service and it immediately fails and I have 
>> the
>
>> following errors in the event log:
>>
>>         The Apache service named  reported the following error:
>>
>>         >>> AH00526: Syntax error on line 243 of
> C:/Apache/conf/httpd.conf:
>> .
>>
>>
>>
>>         The Apache service named  reported the following error:
>>
>>         >>> DocumentRoot must be a directory     .
>>
>>
>>
>> I'm running Apache/2.4.3 (Win64) if that matters. I'm running apache 
>> as an active directory account (ourdomain\apache) and the same 
>> account
>
>> with the same username and password exists on the destination NFS
>> server)
>>
>>
>>
>> I've tried changing the directory to X:/new, X:/new/, X:\new, X:\new\

>> none of the combinations seems to work.
>>
>>
>>
>> I have the same configuration working on a linux box so I don't think

>> the issue is with the NFS server but rather something to do with the 
>> windows/apache box.  Before you suggest that I scrap NFS and use SMB 
>> -
>
>> I've already tried that. SMB works but performance is dreadful (20+ 
>> second load times).
>>
>>
>>
>> I've also configured EnableMMAP off and EnableSendfile off which I 
>> believe is suggested for network file systems. That doesn't help 
>> (either with SMB or NFS). Can anyone help me understand why this is
> failing?
>>
>>
>>
>> Thanks
>>
>> Brad
>>
>>
>
>
>
> --
> Born in Roswell... married an alien...
> http://emptyhammock.com/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>



--
Born in Roswell... married an alien...
http://emptyhammock.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message