httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Laura Martín <hoshi.uts...@gmail.com>
Subject [users@httpd] Cannot compile Apache with APR-util support
Date Fri, 07 Sep 2012 07:39:54 GMT
Hi all,

I'm trying to install Apache 2.2.22 from source code on a Debian testing
box. I installed gcc and libldl2.0.1 and my configure is as follows:

LDFLAGS="-ldl"; export LDFLAGS
"./configure" \
"--prefix=/opt/httpd-2.2.22" \
"--enable-rewrite" \
"--enable-headers" \
"--enable-info" \
"--enable-ssl" \
"--with-apr=/opt/apr-1.4.6/bin/apr-1-config" \
"--with-apr-util=/opt/apr-util-1.4.1/bin/apu-1-config" \
"--with-ssl=/opt/openssl-1.0.1c" \
"LDFLAGS=-ldl" \
"$@"


As you can see, I compiled apr and apr-util, the latest version,


I put 'echo'es in configure script to debug which are the folders where is
Apache looking for apr-util:

[...]
Configuring Apache Portable Runtime library ...

checking for APR... /opt/apr-1.4.6/bin/apr-1-config
yes
[...]

Configuring Apache Portable Runtime Utility library...

checking for APR-util... ___
-rwxr-xr-x 1 root root 6518 Sep 6 13:53 /opt/apr-util-1.4.1/bin/apu-1-config
___
-rwxr-xr-x 1 root root 6518 Sep 6 13:53 /opt/apr-util-1.4.1/bin/apu-1-config
yes
[...]

Configuring Apache httpd ...

  adding "-I/opt/apr-1.4.6/include/apr-1" to INCLUDES
  adding "-I/opt/apr-util-1.4.1/include/apr-1" to INCLUDES

[...]

checking for APR version 1.2.0 or later... yes
checking for APR-util version 1.2.0 or later... no
configure: error: APR-util version 1.2.0 or later is required



*~*~*~*~*~*~*~*

APR and APU configures:

"./configure" \
"--prefix=/opt/apr-1.4.6" \


"./configure" \
"--prefix=/opt/apr-util-1.4.1" \
"--with-apr=/opt/apr-1.4.6" \


Any ideas?


Laura,

Mime
View raw message