httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Werner Schalk" <werner_sch...@gmx.de>
Subject Re: [users@httpd] Weird locking issue with mod_dav
Date Sat, 15 Sep 2012 17:25:32 GMT
Hello,

it is indeed:

drwxr-sr-x 4 apache    apache    4096 15. Sep 14:19 htdocs.webdav

Any further ideas?

Kind regards,
Werner

-------- Original-Nachricht --------
> Datum: Sun, 16 Sep 2012 02:01:50 +1000
> Von: Igor Cicimov <icicimov@gmail.com>
> An: users@httpd.apache.org
> Betreff: Re: [users@httpd] Weird locking issue with mod_dav

> On Sat, Sep 15, 2012 at 11:33 PM, Werner Schalk
> <werner_schalk@gmx.de>wrote:
> 
> > Hello,
> >
> > I am trying to configure webdav for a folder and I am consistently
> hitting
> > a problem: Whenever files are copied to the webdav share, the operation
> > aborts and the error log of Apache contains the following entries:
> >
> > [Sat Sep 15 14:16:27 2012] [error] [client 81.210.X.Y] (2)No such file
> or
> > directory: This resource is locked and an "If:" header was not supplied
> to
> > allow access to the resource.  [423, #0]
> > [Sat Sep 15 14:18:41 2012] [error] [client 81.210.X.Y] Could not LOCK
> > /mydrop/Sample folder/P1290025.JPG due to a failed precondition (e.g.
> other
> > locks).  [423, #0]
> > [Sat Sep 15 14:18:41 2012] [error] [client 81.210.X.Y] (2)No such file
> or
> > directory: Existing lock(s) on the requested resource prevent an
> exclusive
> > lock.  [423, #0]
> >
> > Here is my configuration:
> >
> > DavLockDB "/var/lib/dav/lockdb2"
> > <IfModule setenvif_module>
> > BrowserMatch "Microsoft Data Access Internet Publishing Provider"
> > redirect-carefully
> > BrowserMatch "MS FrontPage" redirect-carefully
> > BrowserMatch "^WebDrive" redirect-carefully
> > BrowserMatch "^WebDAVFS/1.[012345678]" redirect-carefully
> > BrowserMatch "^gnome-vfs/1.0" redirect-carefully
> > BrowserMatch "^XML Spy" redirect-carefully
> > BrowserMatch "^Dreamweaver-WebDAV-SCM1" redirect-carefully
> > </IfModule>
> >
> > <VirtualHost 217.A.B.C:80>
> >
> >         ServerName www.bla.com
> >         DocumentRoot "/home/bla/blubb/htdocs"
> >
> >         <Directory "/home/bla/blubb/htdocs">
> >                 Options None
> >                 AllowOverride AuthConfig
> >                 Order allow,deny
> >                 Allow from all
> >         </Directory>
> >
> >          Alias /mydrop /home/bla/blubb/htdocs.webdav
> >          <Location /mydrop>
> 
>          DAV On
> >         Options Indexes
> >                         AuthType Basic
> >                         AuthName "Drop - Please enter password"
> >                         AuthUserFile
> > /home/bla/blubb/htdocs.webdav/.htpasswd
> >                                                 <Limit GET PUT POST
> DELETE
> > PROPFIND PROPPATCH MKCOL COPY MOVE LOCK UNLOCK>
> >                                 Require valid-user
> >                                                         Order allow,deny
> >                                                         Allow from all
> >                                                 </Limit>
> >         DavMinTimeout 600
> >
> >          </Location>
> >
> >         <IfModule alias_module>
> >                 ScriptAlias /cgi-bin/ "/var/www/myhost/cgi-bin/"
> >         </IfModule>
> >
> >         php_admin_value suhosin.session.encrypt Off
> >
> >         LogLevel Debug
> >
> >         ErrorLog /var/log/apache2/host_x_error_log
> >
> >         <IfModule log_config_module>
> >                 TransferLog /var/log/apache2/host_x_access_log
> >         </IfModule>
> >
> > </VirtualHost>
> >
> > Any ideas? I have already checked the permissions for the lock, but they
> > are fine (file is owned and writable my Apache user, so is the
> directory).
> > Any ideas?
> 
> 
> How about the permissions of "/home/bla/blubb/htdocs.webdav" is it
> writable
> by apache?
> 
> 
> > The Apache version I use is 2.2.22 , mod_dav, mod_dav_lock and
> mod_dav_fs
> > are enabled. The issue happens regardsless of the "Limit" directive. And
> it
> > happens even if I nuke the lock file or create a new one, the problem
> > remains after restarting Apache.
> >
> > Kind regards,
> > Werner
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> > For additional commands, e-mail: users-help@httpd.apache.org
> >
> >

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message