httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fleishman.Mark" <Mark.Fleish...@IGT.com>
Subject RE: [users@httpd] Error compiling httpd 2.2.11 with openssl 0.9.8 on rhel 6
Date Fri, 27 Jul 2012 15:31:44 GMT
Thanks Pete.  I am using this:  "--with-ssl=/apps/openssl/1.0.0x" with my apache compile parameters.

Mark Fleishman
Systems and Apps Admin IV 
(415) 229-8312


-----Original Message-----
From: Pete Houston [mailto:ph1@openstrike.co.uk] 
Sent: Thursday, July 26, 2012 2:14 AM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Error compiling httpd 2.2.11 with openssl 0.9.8 on rhel 6

On Wed, Jul 25, 2012 at 04:56:48PM -0700, Fleishman.Mark wrote:
> I compiled openssl 0.9.8x using these options, and it compiled and installed ok:
> ./config --prefix=/apps/openssl/0.9.8x 
> --openssldir=/apps/openssl/0.9.8x/openssl shared
> 
> Here are the compile options I am using with httpd 2.2.11:
> 
> "./configure" \
> "--prefix=/apps/apache/2.2.11_64" \
> "--enable-so" \
> "--enable-ssl" \
> "-with-ldap" \
> "--enable-mods-shared=all" \
> "--with-ssl=/apps/openssl/1.0.0x/" \
> "--with-mpm=worker" \
> "$@"
> 
> Any assistance would be appreciated.

Well, it does appear at first glance that you are not configuring apache to use the openssl
version you have just compiled. If you change the argument to --with-ssl to be the correct
path, that may be all you need.

HTH,

Pete
--
Openstrike - improving business through open source http://www.openstrike.co.uk/ or call 01722
770036 / 07092 020107

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message