httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fleishman.Mark" <Mark.Fleish...@IGT.com>
Subject [users@httpd] Error compiling httpd 2.2.11 with openssl 0.9.8 on rhel 6
Date Wed, 25 Jul 2012 23:56:48 GMT
Hello,

First question, is httpd 2.2.11 compatible with RHEL6 x86_64 and openssl 0.9.8?

I am trying to compile httpd 2.2.11 on rhel 6 using openssl 0.9.8 but I am receiving an error
during the make:

ssl_engine_init.c: In function 'ssl_init_ctx_verify':
ssl_engine_init.c:549: error: 'STACK' undeclared (first use in this function)
ssl_engine_init.c:549: error: (Each undeclared identifier is reported only once
ssl_engine_init.c:549: error: for each function it appears in.)
ssl_engine_init.c:549: error: expected expression before ')' token
ssl_engine_init.c: In function 'ssl_init_FindCAList':
ssl_engine_init.c:1129: warning: pointer type mismatch in conditional expression
make[4]: *** [ssl_engine_init.slo] Error 1
make[4]: Leaving directory `/tmp/httpd-2.2.11/modules/ssl'
make[3]: *** [shared-build-recursive] Error 1
make[3]: Leaving directory `/tmp/httpd-2.2.11/modules/ssl'
make[2]: *** [shared-build-recursive] Error 1
make[2]: Leaving directory `/tmp/httpd-2.2.11/modules'
make[1]: *** [shared-build-recursive] Error 1
make[1]: Leaving directory `/tmp/httpd-2.2.11'
make: *** [all-recursive] Error 1


I have seen posts about this but with reference to the incompatibility with openssl 1.0.0
so I am trying 0.9.8.

I compiled openssl 0.9.8x using these options, and it compiled and installed ok:
./config --prefix=/apps/openssl/0.9.8x --openssldir=/apps/openssl/0.9.8x/openssl shared

Here are the compile options I am using with httpd 2.2.11:

"./configure" \
"--prefix=/apps/apache/2.2.11_64" \
"--enable-so" \
"--enable-ssl" \
"-with-ldap" \
"--enable-mods-shared=all" \
"--with-ssl=/apps/openssl/1.0.0x/" \
"--with-mpm=worker" \
"$@"

Any assistance would be appreciated.

Thanks



Mime
View raw message