httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mathijs <mathijs...@gmail.com>
Subject Re: [users@httpd] Apache Virtual Hosts, and Zimbra
Date Tue, 24 Jul 2012 18:22:21 GMT
On Tue, Jul 24, 2012 at 6:35 PM, Roger Martinez <roger.martinez.87@gmail.com
> wrote:

> Greetings,
>
> I am an IT intern at a small communications company.  My assignment is to
> set up a Red Hat Enterprise Linux 6 Server to run both Zimbra email client
> and Apache Web Server (to be used to run an SVN client as well as TRAC).
>  This is something I've done before with a different server, possibly
> running different versions of each program.  What I did before doesn't seem
> to work any more.  Here's what I did:
>
> 1) install both Apache and Zimbra
> 2) Configure Zimbra to listen to port 81
> 3) Set up httpd to use Virtual Hosts.  This is what my httpd-vhosts.conf
> file looks like:
>
> NameVirtualHost 10.105.249:80
>

> <VirtualHost 10.105.249.32:80>
>         ServerAdmin admin@incnetservices.net
>         DocumentRoot "/httpdir"
>         ServerName svntrac.incnetservices.net
>         ServerAlias svntrac.incnetservices.net
>         ErrorLog "logs/error_log"
>         CustomLog "logs/access-log" common
> </VirtualHost>
>
> <VirtualHost 10.105.249.32:80>
>         ServerAlias incemail.incnetservices.net
>         ProxyRequests On
>         ProxyPass / http://incemail.incnetservices.net:81
>         ProxyPassReverse / http://incemail.incnetservices.net:81
>         ErrorLog "/var/log/httpd/zimbra-error.log"
> </VirtualHost>
>

You can't use ServerAlias without a ServerName, in this case just replace
it with ServerName.


>
> <VirtualHost 10.105.249.32:443>
>        ServerAlias incemail.*
>        SSLProxyEngine On
>        SSLEngine On
>        SSLCertificateFile /opt/zimbra/ssl/zimbra/server/server.crt
>        SSLCertificateKeyFile /opt/zimbra/ssl/zimbra/server/server.key
>        ProxyPass / http://incemail.incnetservices.net:81
>        ProxyPassReverse / http://incemail.incnetservices.net:81/
>        ErrorLog "/var/log/httpd/zimbra_ssl-error.log"
> </VirtualHost>
>

Same goes for this vhost.


>
> When i start httpd with it gives me the error:
>
> Starting httpd: Syntax error on line 23 of /etc/httpd/httpd-vhosts.conf:
> Invalid command 'SSLProxyEngine', perhaps misspelled or defined by a
> module not included in the server configuration
>                                                            [FAILED]
>
>
> My problem seems to be with whatever module SSLProxyEngine is associated
> with.  How do i fix this?  Or better question, am i setting up the https
> v-host correctly?
>

You seem to be missing the mod_ssl module. Load it using LoadModule and
restart Apache HTTPD, then you will be able to use the directives it
provides, such as SSLProxyEngine.


>
>
> I commented the https vhost section out and tried running httpd and it
> runs.  However, the document root i specified isn't used at all, the
> default Apache page loads.
>

Check the output of 'httpd -S' to see the current VirtualHost
configuration. If you are unsure if its correct or not, share it with the
list.


> Furthermore, the Zimbra admin and user log-in pages don't load at all.
>  When I do an nslookup of the domains they do return the correct IP
> address, but it seems the browser won't return the correct information.
>  Again, I'd like to point out that these are the exact specifications I
> used in the past, but will not work now.  If anyone has experience with
> Zimbra and Apache, any help will be greatly appreciated!
>
>
> Thanks!
>
> --
> Roger Martinez
> Intern
> incNETWORKS, Inc.
>
>
Kind regards,
Mathijs Schmittmann

Mime
View raw message