httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Cicimov <icici...@gmail.com>
Subject Re: [users@httpd] TimeOuts Received.
Date Tue, 31 Jul 2012 00:57:03 GMT
On Mon, Jul 30, 2012 at 11:07 PM, gaurav shrivastava <
g.shrivastava1985@gmail.com> wrote:

> *
> We automated our product
>
> Env -
>
> 4 Managed Serves - WLS weblogic (RHL)
> 1 DB - Oracle (RHL)
> 1 Proxy server - APACHE
>
> What i can see during the execution of and as the user load increases to
> 180 +
> I can see messages of timeouts at RPT console where response is not
> received for the request.
> Surprisingly i can not see any error logs for time outs any where in app
> server logs or proxy server logs.
>
>
> We did a test again with out proxy servers where requests were directly
> hitting the app server every thing works well than no timeouts are noticted.
> So it looks like the issue is with the proxy server do you have any
> suggestions for any tunable parameters.
>
>
> Some of the parameters currently used.
>
> <IfModule worker.c>
> ThreadLimit         2000
> ServerLimit         10
> StartServers        6
> MaxClients         20000
> MinSpareThreads     2000
> #MinSpareThreads     100
> #MaxSpareThreads     20000
> MaxSpareThreads     15000
> ThreadsPerChild     2000
> MaxRequestsPerChild  0
> </IfModule>
>
>
> Help will be highly appreciated.
> *
>
> --
> *Cheers !!
>
> Gaurav ....*
>
>
What OS is apache running on? What is apache version? What is your proxy
configuration? What do you see in the log files, anything related to the
timeouts from mod_proxy? Have you first tested the connectivity between
apache and Weblogic meaning can you even connect from the apache box to the
weblogic port on the other server? Any possible firewall between the
servers?

Mime
View raw message