httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoff Millikan" <gmilli...@t1shopper.com>
Subject [users@httpd] Apache 2.2.22 bug > mod_cache cacheing 403 "Directory index forbidden by Options directive" pages?
Date Fri, 01 Jun 2012 18:36:00 GMT
Two things are going amiss with Apache here.

1. Apache is intermittently issuing a 403 "Directory index forbidden by Options directive"
but it never should.  For example the two
below links work fine.  But look at the log entry showing the 403 error.  Crazy.  I cannot
duplicate the error at all (except see #2
issue below).  I just see it in the logs.  

  http://www.t1shopper.com/tools/calculate/file-size/result?size=123456789&unit=kilobytes

  http://www.t1shopper.com/tools/calculate/file-size/result/

  Here's error log:
  [Fri Jun 01 11:05:06 2012] [error] [client 71.256.256.256] Directory index forbidden by
Options directive:
/home/t1shopper/www/tools/calculate/file-size/result/

2. After grepping through the access logs and finding 403's, I can go to those pages and get
the 403 again (if I use the same
browser as the original requestor) because mod_cache is cacheing the 403!  Here's two entries
in the log file showing the 403
getting served (my local IP address removed) at 11:33:09.  Then I force refresh the page (by
making my browser send in a "no-cache"
in my HTTP request) then the page comes back just fine there at 11:33:18.  I cannot get the
403 to ever come back again.  As long as
I don't send the "Cache-Control: no-cache" I can keep getting served the 403 out of the cache.

 Here's the log file:
 [01/Jun/2012:11:33:09 -0700]    GET /tools/calculate/file-size/result/?size=32&unit=kilobytes
HTTP/1.1  403     302     -
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0     -
 [01/Jun/2012:11:33:18 -0700]    GET /tools/calculate/file-size/result/?size=32&unit=kilobytes
HTTP/1.1  200     3347    -
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0     

So my questions are: Why is the 403 happening at all?  And more importantly, why is mod_cache
serving the 403?????!!!!!!!!!!!!  

Thanks,

Geoff

PS. I suppose I'll open a bug report but wanted to post here first in case I was missing something
basic.



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message