httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ishita Kapadiya <ishim...@gmail.com>
Subject Re: [users@httpd] Segmentation fault error
Date Wed, 30 May 2012 15:32:44 GMT
Thanks Nick.
I have compiled Apache for myself both the time and both are 32-bit.
The same modules all other instances are using and thus i am not sure
what is different with this instance that causing Segmentation fault
error.

I tried to dig more into it and here is what i got -

mdb core
> ::stack
libc.so.1`_read+0xc(6, ffbff5e3, 1, 0, 10b4, fef73ac0)
ap_mpm_pod_check+0x18(d6800, 68764, 68f8c, 1b7ec0, 0, 1)
child_main+0x2d4(0, 682dc, 0, fee58000, fef73700, fedf2a00)
make_child+0x128(9bc00, 0, 1, 9cc00, 9b400, 9c800)
ap_mpm_run+0x740(fe720058, 4, 0, a, 1, 0)
main+0x77c(a7810, 99c00, 9bc00, 9bc00, a5808, 0)
_start+0x5c(0, 0, 0, 0, 0, 0)

pstack core
 fef45874 _read    (6, ffbff5e3, 1, 0, 10b4, fef73ac0) + c
 0006b714 ap_mpm_pod_check (d6800, 68764, 68f8c, 1b7ec0, 0, 1) + 18
 000697b4 child_main (0, 682dc, 0, fee58000, fef73700, fedf2a00) + 2d4
 00069930 make_child (9bc00, 0, 1, 9cc00, 9b400, 9c800) + 128
 0006a160 ap_mpm_run (fe720058, 4, 0, a, 1, 0) + 740
 00029bc8 main     (a7810, 99c00, 9bc00, 9bc00, a5808, 0) + 77c
 00028f7c _start   (0, 0, 0, 0, 0, 0) + 5c

pmap core
00010000     448K r-x--  /abc/apache-2.2.22/bin/httpd
00080000      32K r-x--
00096000      24K rwx--  /abc/apache-2.2.22/bin/httpd
0009C000      16K rwx--  /abc/apache-2.2.22/bin/httpd
000A0000    6528K rwx--    [ heap ]
FAB7A000       8K rw---    [ stack tid=36 ]
...
(removed rest of the lines to avoid length)

mdb /abc/apache-2.2.22/bin/httpd

> ::dis ap_mpm_pod_check!head
ap_mpm_pod_check:               save      %sp, -0x78, %sp
ap_mpm_pod_check+4:             ld        [%i0], %o1
ap_mpm_pod_check+8:             call      +0x2d0e0      <PLT:apr_os_file_get>
ap_mpm_pod_check+0xc:           add       %fp, -0x14, %o0
ap_mpm_pod_check+0x10:          ld        [%fp - 0x14], %o0
ap_mpm_pod_check+0x14:          add       %fp, -0x15, %o1
ap_mpm_pod_check+0x18:          call      +0x2cdc4      <PLT:read>
ap_mpm_pod_check+0x1c:          mov       1, %o2

Please help me what could be the problem? It's affecting my production
env and i really don't know what to do next?

On Tue, May 29, 2012 at 7:15 PM, Nick Kew <nick@webthing.com> wrote:
>
> On 29 May 2012, at 23:11, Ishita Kapadiya wrote:
>
>> Hi All,
>>
>> I am using this configurations -
>>
>> Solaris sparc 10/apache 2.2.22/openssl 1.0.0g/simteminder sso/mod-jk 1.30
>
> Did you compile everything yourself?
>
> If yes, could any compile options have changed?  E.g. between 32-bit and 64-bit,
> or something less obvious but just as important?
>
> If no, what suppliers do your binaries come from, and have you checked with them?
>
> --
> Nick Kew
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message