httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Piotr Kloc" <...@rdl.pl>
Subject Re: [users@httpd] modules/arch/unix/
Date Tue, 22 May 2012 17:17:19 GMT
I see the mod_fcgid is already ready for apache 2.4 but
but mod_fcgid is not correctl checking for suexec

mod_fcgid compiled with /usr/include/apache/unixd.h
and there is

typedef struct {
    const char *user_name;
    const char *group_name;
    uid_t user_id;
    gid_t group_id;
    int suexec_enabled;
    const char *chroot_dir;
    const char *suexec_disabled_reason; /* suitable msg if !suexec_enabled */
} unixd_config_rec;
AP_DECLARE_DATA extern unixd_config_rec ap_unixd_config;


So how we can set suexec_enabled to 1 ? because now mod_fcgid detect it as disable
and tried to use old  ap_unixd_setup_child()


Suexec in apache 2.4 is compiled correctly and wrapper exists
-rwsr-xr-x 1 root root 23K maj 22 19:03 /usr/sbin/suexec


Regards,
Piotr

  ----- Original Message ----- 
  From: Piotr Kloc 
  To: users@httpd.apache.org 
  Sent: Tuesday, May 22, 2012 5:53 PM
  Subject: [users@httpd] modules/arch/unix/


  Hello !

  its possible to build this module in apache 2.4 ?
  I need it for mod_fcgid and ap_unixd_setup_child()

  Regards,
  Piotr
Mime
View raw message