httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Billy Baker <bi...@teknobilly.com>
Subject [users@httpd] Build 2.4.2 RPMs fails on Centos 6.2 for ?deprecated? dependancy distcache
Date Fri, 20 Apr 2012 03:34:18 GMT
Greets,
I'm building the httpd 2.4.2 RPM packages for our systems.

Using Centos 6.2 I have built RPM's for APR 1.4 and APR-devel 1.4 those
installed fine.  I thought this was going to be easy. :)

All other dependencies have been cleared but the last.  distcache-devel.

I'm wondering if distcache-devel is really necessary?  on the front page of
distcache.org there is a message:

      good news is that distcache support code is now
      maintained in Apache's CVS, which means it
      should be present in releases from 2.1 onwards.
      For now, the 2.0 support has been updated for httpd-2.0.52.

I am guessing distcache-devel may be integrated directly into httpd-devel.
- or -
http.spec - indicates mod_socache_dc requires distcache
(I could live without this mod. (I think) so I tried commenting it out.
 Didn't work)

I have tried to install distcache, but 'make' fails with an error regarding
an undeclared function.
I have not been able to find any rpms of distcache-devel for 6.2

This thread last month indicates another user had this issue
http://mail-archives.apache.org/mod_mbox/httpd-users/201203.mbox/%3C4F68F007.4060609%40visuallink.com%3E

Ideas
Thanks, Billy

Mime
View raw message