httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shuvalov Roman <rshuva...@hotmail.com>
Subject RE: [users@httpd] Unable to build 2.4 because "Bundled APR not found" FreeBSD 9.0
Date Mon, 23 Apr 2012 15:15:37 GMT
Hi, Bernard,

I had similar issue, though I tried to compile Apache 2.4.2 under CentOS 6.2
- see of these tips will be usefull to you:
	
1. For Apache 2.4.x - you need apr and apr-util 1.4.x or later (means most
probably you do not have them yet in you OS repos and need manually download
them form http://apr.apache.org/download.cgi
2. Extract them to ./srclib/apr and ./srclib/apr-util directory
respectively.
3. Download -deps files for your Apache build from
http://httpd.apache.org/download.cgi#apache24 (I used this one  -
http://www.sai.msu.su/apache//httpd/httpd-2.4.2-deps.tar.gz )
4. Extract -deps files to your ./srclib/apr directory
5. Use --with-included-apr switch with ./configure script

Also, I have error messages issued by ./configure script on APR stuff just
because I did not have gcc compiler installed on my machine. Well, whatever
- I installed gcc package and ./configure run smoothly. Also, in my case I
needed to install pcre-devel package - see if you need it too. After all
these steps I was able to ./configure the sources, "make" and "make install"
them without problems.

One more tip: I do not know how to remove it if you do not like it, "make
uninstall" will not work :) . So, to install the Apache,  I used ./configure
with no --prefix switch (and any other directory fine-tuning switches)
which, I believe, put the all the files into /usr/local/apache2 directory,
so removal should be simply removing this directory, but again I am not
sure, I just avoided to abuse all those directory fine tuning switched to
prevent the product be all over the place.

I wonder if any of those tips helped you,

Good luck,
Roman.

-----Original Message-----
From: Bernard T. Higonnet [mailto:bthcom@higonnet.net] 
Sent: Monday, April 23, 2012 12:15 PM
To: users@httpd.apache.org
Subject: [users@httpd] Unable to build 2.4 because "Bundled APR not found"
FreeBSD 9.0

The exact error message during ./config_nice (of a working 2.2 installation
on another machine) is

Bundled APR requested but not found at ./srclib/. Download and unpack the
corresponding apr and apr-util packages to ./srclib/.


I went to http://apr.apache.org/download.cgi and downloaded apr-1 and 
apr-util.

As for apr-1, I found a a setup for building (configure, make etc.) 
which appeared to be successful. Nowhere did I see anything to "unpack 
to srclib"

As for apr-util, I can't build because

configure: error: APR could not be located. Please use the --with-apr 
option.

This option requires a "path to installed APR or the full path to 
apr-config"


So I seem to be going around in circles and any help would of course be 
appreciated.

Bernard Higonnet

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message