httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Serge Fonville <serge.fonvi...@gmail.com>
Subject Re: [users@httpd] reverse proxy via mod_proxy returns HTTP 500 error
Date Sat, 24 Mar 2012 22:41:35 GMT
Hi,

> What I'm trying to achieve is defining a reverse proxy rule that defers all traffic to
-say- <http://mydomain/tomcat/> to the Tomcat server running on port 8080.

Does http://tomcat.apache.org/tomcat-7.0-doc/proxy-howto.html apply?

Kind regards/met vriendelijke groet,

Serge Fonville

http://www.sergefonville.nl

Convince Google!!
They need to add GAL support on Android (star to agree)
http://code.google.com/p/android/issues/detail?id=4602



2012/3/24 ron.vandenbranden@home <ron.vandenbranden@kantl.be>:
> Hi,
>
> I'm trying to configure reverse proxy rules in vhost.conf. I have
> Apache-2.2.8 on Ubuntu-8.04 (monitored by Plesk-10.4.4).
>
> What I'm trying to achieve is defining a reverse proxy rule that defers all
> traffic to -say- <http://mydomain/tomcat/> to the Tomcat server running on
> port 8080. I have mod_rewrite and mod_proxy loaded in Apache. As far as I
> understand mod_proxy docs, entering following rules in a vhost.conf file
> should work:
>
>   <Proxy *>
>     Order deny,allow
>     Allow from all
>   </Proxy>
>
>   ProxyRequests off
>   RewriteRule ^/tomcat/(.*)$ http://mydomain:8080/$1 [P]
>
> (Note: I tested with a RewriteRule directive to get at least some logging.)
> Yet, I am getting a HTTP 500: internal server error when requesting above
> URL.
>
> I have made mod_rewrite log extensively, and find following entries in the
> logs:
>
>   81.241.230.23 - - [19/Mar/2012:16:42:59 +0100]
> [mydomain/sid#b06ab8][rid#1024af8/initial] (2) init rewrite engine with
> requested uri /tomcat/testApp/
>   81.241.230.23 - - [19/Mar/2012:16:42:59 +0100]
> [mydomain/sid#b06ab8][rid#1024af8/initial] (3) applying pattern
> '^/tomcat/(.*)$' to uri '/tomcat/testApp/'
>   81.241.230.23 - - [19/Mar/2012:16:42:59 +0100]
> [mydomain/sid#b06ab8][rid#1024af8/initial] (2) rewrite '/tomcat/testApp/' ->
> 'http://mydomain:8080/testApp/'
>   81.241.230.23 - - [19/Mar/2012:16:42:59 +0100]
> [mydomain/sid#b06ab8][rid#1024af8/initial] (2) forcing proxy-throughput with
> http://mydomain:8080/testApp/
>   81.241.230.23 - - [19/Mar/2012:16:42:59 +0100]
> [mydomain/sid#b06ab8][rid#1024af8/initial] (1) go-ahead with proxy request
> proxy:http://mydomain:8080/testApp/ [OK]
>
> This suggests that the rewrite and proxy part are processed ok; still the
> proxied request produces a 500 error. Addressing the testApp directly via
> <http://mydomain:8080/testApp> does work, and the same setup does work on my
> local computer.
>
> Does anyone have an idea what might be wrong, or how I at least can get more
> useful information than 'internal server error' (apart from above rewrite
> logs, I can't find any trace of this request in other logs).
>
> Any pointers much appreciated!
>
> Ron

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message