httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Serge Fonville <serge.fonvi...@gmail.com>
Subject Re: [users@httpd] site loads correctly using lan ip, but not from other computers on same lan
Date Sun, 18 Mar 2012 02:11:42 GMT
Also,

does your URL change when you visit the pages.

Since I'd expect proxypass and proxypassreverse to refer to the same url

Kind regards/met vriendelijke groet,

Serge Fonville

http://www.sergefonville.nl

Convince Google!!
They need to add GAL support on Android (star to agree)
http://code.google.com/p/android/issues/detail?id=4602



2012/3/18 Serge Fonville <serge.fonville@gmail.com>:
> Hi,
>
> Two things:
>
> Have you read into AllowCONNECT
> Have you read the logs and could you post any relevant entries
>
> HTH
> Kind regards/met vriendelijke groet,
>
> Serge Fonville
>
> http://www.sergefonville.nl
>
> Convince Google!!
> They need to add GAL support on Android (star to agree)
> http://code.google.com/p/android/issues/detail?id=4602
>
>
>
> 2012/3/18 Joon Lee <jundowon@gmail.com>:
>> Hi, I've got a configuration using ProxyPass for a webapp running on
>> localhost to be accessible from example.com:9999 and a wordpress blog on
>> example.com:80. the httpd.conf vhost setting like this:
>>
>>
>> <VirtualHost *:9999>
>> ServerAdmin admin@example.com
>> ServerName www.example.com
>> ServerAlias example.com
>>
>> # Indexes + Directory Root.
>> DirectoryIndex index.php
>> DocumentRoot /var/www/html/example.com/wordpress
>>
>> ProxyRequests Off
>> <Proxy *>
>> Order deny,allow
>> Allow from all
>> </Proxy>
>> ProxyPass / http://localhost:8888/
>> ProxyPassReverse / http://www.example.com:9999/
>> #ProxyPassReverseCookieDomain localhost:8888 www.example.com:9999/
>> ProxyPassReverseCookiePath / /
>>
>> </VirtualHost>
>> <VirtualHost *:80>
>> ServerAdmin admin@example.com
>> ServerName www.example.com
>> ServerAlias example.com
>>
>> # Indexes + Directory Root.
>>
>> DirectoryIndex index.php
>> DocumentRoot /var/www/html/example.com/wordpress
>> </VirtualHost>
>>
>>
>> the computer (192.168.1.5) running apache itself is trying to serve
>> wordpress from the standard example.com and proxy a localhost app on port
>> 9999 (example.com:9999) to the internet. the wordpress site works from
>> 192.168.1.5 from anywhere on the network (on port 80), but the localhost app
>> proxy on 192.168.1.5:9999 works on 192.168.1.5 itself but not on other
>> computers within the network. why would it only work on the originating
>> server and not its peers?

Als

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message