httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Cicimov <icici...@gmail.com>
Subject Re: [users@httpd] httpd crashes with segmentation fault: Incompatible libpng version in application and library
Date Sun, 18 Mar 2012 23:08:31 GMT
Two things that come to my mind atm:

1. Link the existing “libpng.so” installed to the one you compiled
or
2. Try using FileLoad directive in the httpd.conf to load the correct
"libpng.so" file

Igor

On Sun, Mar 18, 2012 at 10:24 PM, Lenin <lenin.lee@gmail.com> wrote:

> Hi,
>
> I've compiled httpd 2.2.21 and php 5.3.10, the version of libpng I used is
> 1.5.7, and I installed all the three packages under a custom path under
> /opt.
>
> The OS is CentOS 6.2, which contains an official distribution of libpng,
> the version is 1.2.46.
>
> When I start the server and visit programs hosted on it, the error.log
> keeps being appended with the following messages:
>
> *libpng warning: Application was compiled with png.h from libpng-1.5.7
> libpng warning: Application  is  running with png.c from libpng-1.2.46
> gd-png:  fatal libpng error: Incompatible libpng version in application
> and library*
>
> I know the reason is that the version running with is not the one compiled
> with. But setting the environment variable LD_LIBRARY_PATH won't solve the
> problem.
>
> Can anybody tell me how to fix this ? I know removing the old version of
> libpng or recompile the server using the old version may be ok, but there
> are some other potential problems, so I just want to run my application
> server with the new version of libpng compiled by my self.
>
> Thanks
>

Mime
View raw message