httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Tréguier <Bruno.Tregu...@shom.fr>
Subject Re: [users@httpd] Problem when mixing RewriteRules and <Location> directives
Date Fri, 23 Mar 2012 10:08:33 GMT
Le 23/03/2012 07:09, Bruno Tréguier a écrit :
> Le 23/03/2012 à 1:37, Igor Cicimov a écrit :
>> This is very interesting problem and I thought the issue was the typo
>> leaving your var empty. I'll have to do some research about the
>> mod_rewrite myself to confirm it precedes SetEnvIf in the order of
>> execution.
>>
>> Now I'm really curious about the solution my self and will try to find
>> some explanation even test this on one of my apaches if i find time to
>> do that.
>>
>> Have you tried this:
>>
>> Header add X-Debug-Request-URI "%{REQUEST_URI}i"
>
> Hi Igor,
>
> This leads to an error message at Apache restart time:
>
> Unrecognized header format %i
>
>
>> i think the difference is that the character "e" at the end means output
>> value and "i" means the input value of the REQUEST_URI.
>
> Doesn't seem to work, I'll check that out when I'm at work (answering
> from home at the moment).

I have just checked: unfortunately there doesn't seem to be a way to get 
the "input" value. The only modifier apart from "e" is "s", meaning that 
you want to get one of the SSL related variables.

No way to change the modules execution priority either. Looks like I'm 
doomed. :-/

Bruno

-- 
- Service Hydrographique et Oceanographique de la Marine  -  DMGS/INF
-  13, rue du Chatellier -  CS 92803  - 29228 Brest Cedex 2, FRANCE
-     Phone: +33 2 98 22 17 49  -  Email: Bruno.Treguier@shom.fr

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message