httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pablo <pablo.arma...@dattatec.com>
Subject Re: [users@httpd] mod_fcgid 2.3.6 causes Apache 2.4.1 not to start with undefined symbol: ap_unixd_setup_child message
Date Wed, 21 Mar 2012 15:53:53 GMT
Please see this URL: 
https://mail-archives.apache.org/mod_mbox/httpd-users/201203.mbox/browser



On 03/21/2012 12:40 PM, Richard Westebbe wrote:
> Hello,
>
> I'm building several RPM's for CentOS 6.2 to get an LAMP environment 
> with Apache 2.4.1 to work. With mod_fcgid I've got a strange problem I 
> could'nt find a solution for in the web. When I try to load the module 
> Apache won't start with the following message:
>
>
> Starting httpd: httpd: Syntax error on line 46 of 
> /etc/httpd/conf/httpd.conf: Syntax error on line 7 of 
> /etc/httpd/mods-enabled/mod_fcgid.load: Cannot load 
> /etc/httpd/modules/mod_fcgid.so into server: 
> /etc/httpd/modules/mod_fcgid.so: undefined symbol: ap_unixd_setup_child
>
>
> Within a forum thread I read that ap_unixd_setup_children() isn't 
> available anymore in Apache 2.4.1. There they recomended to use the 
> trunk version of mod_fcgid, what I did. With the same result...
>
> When I searched the source code of Apache 2.4.1 for this function I 
> found it declared in mod_unixd.h. So I would say it is still available 
> in Apache 2.4.1, which makes me wonder what the problem might be. 
> Further research in the web and this mailing lists archive didn't 
> help. That why I ask you for assistance.
>
> The build part of my spec for mod_fcgid file looks like this:
>
> %build
> ./configure.apxs
> make %{?_smp_mflags}
>
> It compiles without any error messages.
>
>
> Does anybody have an idea what's going wrong, or what I might be doing 
> wrong? I'm going on to look for a solution for myself, but I would 
> appreciate any help. This project takes much to much time...
>
> Thanks a lot in advance!
>
> Kind regards
>
> Richard Westebbe

Mime
View raw message