httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anam Ali Khan <anamalik...@yahoo.com>
Subject Re: [users@httpd] Different pages served depending on IP address or domain addressing
Date Sat, 17 Mar 2012 17:21:18 GMT
Try this!


UseCanonicalName Off
ServerAlias www.mydomain.com

Remove :80 in ServerName directive

Make sure DNS records are properly configure.

-Anam


________________________________
 From: Prasanna Mulgaonkar <prasanna.mulgaonkar@gmail.com>
To: users@httpd.apache.org 
Sent: Saturday, 17 March 2012, 5:17
Subject: [users@httpd] Different pages served depending on IP address or domain addressing
 
Have a strange setup behavior that I have not been able to find an answer to.

I have a server running Apache set up at IP address 50.X.Y.Z

I have www.mydomain.com redirected from our domain hoster to that ip address.


At the top level of that apache stack (/var/www/html), i have an index.html file that serves
up correctly whether I enter http://www.mydomain.com or http://50.X.Y.Z into the browser address.

I have an application in a subdirectory below the html file in /var/www/html/app. If I say
http://50.X.Y.Z/app/, the app serves up correctly. We have been doing that for may months
now.

However, if I try http://www.mydomain.com/app/, I do not get the app–I get the same index.html
file that is served as if the /app/ was not appended to the end of the mydomain.com. There
are no errors or notices in the apache error file.


The httpd.conf file declares
ServerName www.mydomain.com:80
UseCanonicalName On

There are no vhosts set up.

What else should I look at to explain this odd behavior.

Thanks.





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org
Mime
View raw message